Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2098905 - F37FailsToInstall: python3-falcon
Summary: F37FailsToInstall: python3-falcon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-falcon
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George 🤠
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On: 2099139
Blocks: F38FailsToInstall F37BetaFreezeException PYTHON3.11 F37FailsToInstall 2102851
TreeView+ depends on / blocked
 
Reported: 2022-06-20 09:36 UTC by Miro Hrončok
Modified: 2022-09-02 22:26 UTC (History)
5 users (show)

Fixed In Version: python-falcon-4.0.0~^1.3816217-1.fc38 python-falcon-4.0.0~^1.3816217-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-02 22:26:43 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github falconry falcon issues 2072 0 None open CPython 3.11 support 2022-07-14 15:20:13 UTC

Description Miro Hrončok 2022-06-20 09:36:16 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-falcon) Fails To Install in Fedora 37:

can't install python3-falcon:
  - nothing provides python(abi) = 3.10 needed by python3-falcon-3.0.1-2.fc36.x86_64
  - nothing provides python3.10dist(python-mimeparse) >= 1.5.2 needed by python3-falcon-3.0.1-2.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --disablerepo='*' --enablerepo=local install python3-falcon


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-06-20 10:07:09 UTC
This bugzilla is likely a fallout from the Python 3.11 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.11 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.11, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

If this is not Python 3.11 related, please remove the PYTHON3.11 blocking tracker.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Miro Hrončok 2022-06-27 14:57:54 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Ben Beasley 2022-07-14 13:10:08 UTC
This is blocked on python-uvicorn:

>  Problem: cannot install the best candidate for the job
>   - nothing provides python(abi) = 3.10 needed by python3-uvicorn-0.15.0-2.fc36.noarch
>   - nothing provides python3.10dist(asgiref) >= 3.4 needed by python3-uvicorn-0.15.0-2.fc36.noarch
>   - nothing provides python3.10dist(click) >= 7 needed by python3-uvicorn-0.15.0-2.fc36.noarch
>   - nothing provides python3.10dist(h11) >= 0.8 needed by python3-uvicorn-0.15.0-2.fc36.noarch

Comment 4 Ben Beasley 2022-07-14 15:20:13 UTC
==================================== ERRORS ====================================
______________ ERROR collecting tests/asgi/test_asgi_conductor.py ______________
ImportError while importing test module '/builddir/build/BUILD/falcon-3.0.1/tests/asgi/test_asgi_conductor.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.11/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/asgi/test_asgi_conductor.py:5: in <module>
    from falcon.asgi import App
../../BUILDROOT/python-falcon-3.0.1-2.fc37.x86_64/usr/lib64/python3.11/site-packages/falcon/asgi/__init__.py:35: in <module>
    from .app import App
../../BUILDROOT/python-falcon-3.0.1-2.fc37.x86_64/usr/lib64/python3.11/site-packages/falcon/asgi/app.py:46: in <module>
    from .response import Response
../../BUILDROOT/python-falcon-3.0.1-2.fc37.x86_64/usr/lib64/python3.11/site-packages/falcon/asgi/response.py:17: in <module>
    from asyncio.coroutines import CoroWrapper  # type: ignore
E   ImportError: cannot import name 'CoroWrapper' from 'asyncio.coroutines' (/usr/lib64/python3.11/asyncio/coroutines.py)

[… many similar errors omitted …]

=============================== warnings summary ===============================
../../BUILDROOT/python-falcon-3.0.1-2.fc37.x86_64/usr/lib64/python3.11/site-packages/falcon/media/__init__.py:4
  /builddir/build/BUILDROOT/python-falcon-3.0.1-2.fc37.x86_64/usr/lib64/python3.11/site-packages/falcon/media/__init__.py:4: DeprecationWarning: 'cgi' is deprecated and slated for removal in Python 3.13
    from .handlers import Handlers

../../../../usr/lib/python3.11/site-packages/pytest_asyncio/plugin.py:191
  /usr/lib/python3.11/site-packages/pytest_asyncio/plugin.py:191: DeprecationWarning: The 'asyncio_mode' default value will change to 'strict' in future, please explicitly use 'asyncio_mode=strict' or 'asyncio_mode=auto' in pytest configuration file.
    config.issue_config_time_warning(LEGACY_MODE, stacklevel=2)

-- Docs: https://docs.pytest.org/en/stable/how-to/capture-warnings.html
=========================== short test summary info ============================
ERROR tests/asgi/test_asgi_conductor.py
ERROR tests/asgi/test_asgi_helpers.py
ERROR tests/asgi/test_asgi_servers.py
ERROR tests/asgi/test_boundedstream_asgi.py
ERROR tests/asgi/test_buffered_reader.py
ERROR tests/asgi/test_example_asgi.py
ERROR tests/asgi/test_hello_asgi.py
ERROR tests/asgi/test_lifespan_handlers.py
ERROR tests/asgi/test_request_body_asgi.py
ERROR tests/asgi/test_request_context_asgi.py
ERROR tests/asgi/test_response_media_asgi.py
ERROR tests/asgi/test_scheduled_callbacks.py
ERROR tests/asgi/test_scope.py
ERROR tests/asgi/test_sse.py
ERROR tests/asgi/test_sync.py
ERROR tests/asgi/test_testing_asgi.py
ERROR tests/asgi/test_ws.py
!!!!!!!!!!!!!!!!!!! Interrupted: 17 errors during collection !!!!!!!!!!!!!!!!!!!
======================== 2 warnings, 17 errors in 2.35s ========================



See also:

CPython 3.11 support
https://github.com/falconry/falcon/issues/2072

Comment 5 Ben Cotton 2022-08-09 13:39:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 6 Miro Hrončok 2022-08-25 09:49:38 UTC
This Bugzilla was ASSIGNED on 2022-07-16 but nothing happened. We are past Fedora 37 Beta Freeze and this package does not even install. What is the plan wrt this package? Can it please be removed from the distribution until this is solved?

Comment 7 Carl George 🤠 2022-08-25 18:47:31 UTC
https://github.com/falconry/falcon/issues/2072 was just closed a few hours ago.  I'll work on getting a snapshot build completed that includes those changes to resolve this.

Comment 8 Fedora Update System 2022-08-26 00:23:10 UTC
FEDORA-2022-117afd6866 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-117afd6866

Comment 9 Fedora Update System 2022-08-26 00:25:07 UTC
FEDORA-2022-117afd6866 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-08-26 01:52:04 UTC
FEDORA-2022-8696b2adb3 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-8696b2adb3

Comment 11 Fedora Update System 2022-08-26 10:33:34 UTC
FEDORA-2022-8696b2adb3 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-8696b2adb3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-8696b2adb3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Miro Hrončok 2022-08-29 10:48:37 UTC
(In reply to Carl George 🤠 from comment #7)
> https://github.com/falconry/falcon/issues/2072 was just closed a few hours
> ago.  I'll work on getting a snapshot build completed that includes those
> changes to resolve this.

Is the ~^ in the version intentional?

Comment 13 Miro Hrončok 2022-08-29 10:48:47 UTC
*** Bug 2122147 has been marked as a duplicate of this bug. ***

Comment 14 Carl George 🤠 2022-08-29 22:32:17 UTC
> Is the ~^ in the version intentional?

Yes.  It is a pre-release snapshot of version 4.0.0.  Upstream hasn't tagged a beta or RC, so I believe this is the correct notation.  It certainly sorts correctly.

$ rpmdev-vercmp 4.0.0~^1.3816217-1.fc37 4.0.0~beta1-1.fc37
4.0.0~^1.3816217-1.fc37 < 4.0.0~beta1-1.fc37

$ rpmdev-vercmp 4.0.0~^1.3816217-1.fc37 4.0.0-1.fc37
4.0.0~^1.3816217-1.fc37 < 4.0.0-1.fc37

Comment 15 Adam Williamson 2022-09-02 17:06:35 UTC
+5 in https://pagure.io/fedora-qa/blocker-review/issue/875 , marking accepted.

Comment 16 Fedora Update System 2022-09-02 22:26:43 UTC
FEDORA-2022-8696b2adb3 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.