Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2098978 - F37FailsToInstall: python3-jep
Summary: F37FailsToInstall: python3-jep
Keywords:
Status: CLOSED DUPLICATE of bug 2104094
Alias: None
Product: Fedora
Classification: Fedora
Component: python-jep
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F38FailsToInstall F37FinalFreezeException PYTHON3.11 F37FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-06-20 09:38 UTC by Miro Hrončok
Modified: 2022-09-21 21:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-21 16:44:17 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 2003425 0 unspecified ASSIGNED python-jep-4.1.1 is available 2023-09-10 15:06:27 UTC
Red Hat Bugzilla 2098787 0 unspecified CLOSED F37FailsToInstall: python3-py4j 2022-10-04 13:45:11 UTC

Internal Links: 2003425

Description Miro Hrončok 2022-06-20 09:38:21 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-jep) Fails To Install in Fedora 37:

can't install python3-jep:
  - nothing provides python(abi) = 3.10 needed by python3-jep-3.9.1-5.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --disablerepo='*' --enablerepo=local install python3-jep


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-06-20 10:08:35 UTC
This bugzilla is likely a fallout from the Python 3.11 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.11 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.11, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

If this is not Python 3.11 related, please remove the PYTHON3.11 blocking tracker.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Miro Hrončok 2022-06-27 14:58:29 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Raphael Groner 2022-06-27 16:19:56 UTC
No free time available to look into this actually, sorry.

Comment 4 Ben Cotton 2022-08-09 13:39:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 5 Miro Hrončok 2022-08-25 09:52:05 UTC
(In reply to Raphael Groner from comment #3)
> No free time available to look into this actually, sorry.

We are past Fedora 37 Beta Freeze and this package does not even install. What is the plan wrt this package? Can it please be removed from the distribution until this is solved?

Comment 6 Raphael Groner 2022-09-10 12:39:56 UTC
What happens if you do dnf install python3.10 in prior? Maybe dnf can not resolve versioned dependency of python(abi).

Comment 7 Miro Hrončok 2022-09-10 14:57:10 UTC
(In reply to Raphael Groner from comment #6)
> What happens if you do dnf install python3.10 in prior? Maybe dnf can not
> resolve versioned dependency of python(abi).

https://bugzilla.redhat.com/show_bug.cgi?id=2098787#c7

Comment 8 Raphael Groner 2022-09-12 19:41:04 UTC
Okay, let's continue general discussion in bug #2098787.

Comment 9 Raphael Groner 2022-09-12 22:48:26 UTC
Upstream does not support python 3.11 yet. Please feel free to ask there for a separate test with.
https://ci.appveyor.com/project/ninia/jep/builds/42956348

Comment 10 Miro Hrončok 2022-09-13 09:05:56 UTC
That's no reason to close this Bugzilla without any action. The package still does not install in Fedora 37 and 38.

Should we remove it from Fedora 37/38 before it is fixed?

Comment 11 Raphael Groner 2022-09-14 22:43:04 UTC
Continue within bug #2003425.

Comment 12 Raphael Groner 2022-09-16 18:56:01 UTC
No idea if we can expect an upstream patch soon(ish), as in bug 2003425 currently 4.0.3 misses proper support for python 3.11 .

Comment 13 Geoffrey Marr 2022-09-19 18:23:43 UTC
Discussed during the 2022-09-19 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException (Final)" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-09-19/f37-blocker-review.2022-09-19-16.00.txt

Comment 14 Raphael Groner 2022-09-21 09:55:11 UTC
Thanks for freeze exception. That sounds seriously. - Could you provide another rebuild with proper build.log to get real cause for FTBFS? Maybe we'd try with 4.0.3 as proposed with bug #2003425.

Comment 15 Miro Hrončok 2022-09-21 13:30:41 UTC
Rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=92249489
F37: https://koji.fedoraproject.org/koji/taskinfo?taskID=92249496

BTW You can submit the builds yourself, there is nothing special about them.

Comment 16 Miro Hrončok 2022-09-21 13:38:53 UTC
DEBUG util.py:443:  No matching package to install: 'java-devel'

It seems this package needs to use ExclusiveArch: %{java_arches}

Comment 17 Raphael Groner 2022-09-21 16:44:17 UTC
(In reply to Miro Hrončok from comment #16)
> DEBUG util.py:443:  No matching package to install: 'java-devel'
> 
> It seems this package needs to use ExclusiveArch: %{java_arches}

Thanks. This is bug #2104094 then.

*** This bug has been marked as a duplicate of bug 2104094 ***

Comment 18 Raphael Groner 2022-09-21 16:46:37 UTC
> BTW You can submit the builds yourself, there is nothing special about them.

Sorry - no build client available at the moment. But I'm working on a new machine. Please keep being patient.

Comment 19 Miro Hrončok 2022-09-21 21:35:39 UTC
Not necessarily a dupe. This might just block the actual failure.


Note You need to log in before you can comment on or make changes to this bug.