Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2100815 - Rebuild the avocado module with Python 3.11
Summary: Rebuild the avocado module with Python 3.11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: avocado
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cleber Rosa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: FailedQA AcceptedFreezeException
Depends On:
Blocks: F38FailsToInstall F37FinalFreezeException PYTHON3.11 F37FailsToInstall 2100819
TreeView+ depends on / blocked
 
Reported: 2022-06-24 11:01 UTC by Miro Hrončok
Modified: 2022-10-26 10:44 UTC (History)
7 users (show)

Fixed In Version: avocado-82lts-3720221005102421.9e842022 avocado-latest-3720221012081437.9e842022
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-26 10:17:20 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-06-24 11:01:58 UTC
When I run this command:

$ repoquery --setopt=*.module_hotfixes=yes --repo=rawhide-modular --whatrequires 'python(abi) = 3.10'  --whatrequires 'libpython3.10.so.1.0()(64bit)' --source

I get:

python-aexpect-1.6.2-1.module_f37+14043+581035aa.src.rpm
python-aexpect-1.6.2-1.module_f37+14045+986f5bf2.src.rpm
python-avocado-82.0-4.module_f37+14045+986f5bf2.src.rpm
python-avocado-97.0-1.module_f37+14546+4e1de54b.src.rpm

I assume this comes from two streams of the avocado module.

Please rebuild the package in Fedora 37 with Python 3.11 at the earliest convenience or the following packages won't be installable in Fedora 37:

python3-aexpect-0:1.6.2-1.module_f37+14043+581035aa.noarch
python3-aexpect-0:1.6.2-1.module_f37+14045+986f5bf2.noarch
python3-avocado-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-glib-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-golang-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-golang-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-loader-yaml-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-output-html-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-output-html-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-result-upload-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-result-upload-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-resultsdb-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-resultsdb-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-varianter-cit-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-cit-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-varianter-pict-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-pict-0:97.0-1.module_f37+14546+4e1de54b.noarch
python3-avocado-plugins-varianter-yaml-to-mux-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-yaml-to-mux-0:97.0-1.module_f37+14546+4e1de54b.noarch


Thanks

Comment 1 Miro Hrončok 2022-07-04 12:07:19 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this module, consider orphaning it.

Comment 2 lnie 2022-07-06 09:26:42 UTC
Hi Cleber and Merlin,

 Would you please spare some time on this?Thanks a lot.As you know,avocado-vt depends on avocado.

Thanks,
Lili

Comment 3 Miro Hrončok 2022-08-02 14:49:45 UTC
Could you please rebuild this module or update this Bugzilla with some information (such as what it is blocked on or if there is a build failure...)?

Comment 4 Cleber Rosa 2022-08-10 16:50:48 UTC
Update for F37 and rawhide:

https://bodhi.fedoraproject.org/updates/FEDORA-2022-4ee3339f88
https://bodhi.fedoraproject.org/updates/FEDORA-2022-57b8fd1563

Should be enough to close this BZ.

Comment 5 Miro Hrončok 2022-08-10 23:22:51 UTC
Neither of the listed updates is for the modular avocado, hence it is not enough to close this bugzilla which is requesting the rebuild of modular avocado.

Comment 6 Miro Hrončok 2022-08-15 11:54:53 UTC
The Rawhide modular repo has had no packages at all since branching. The reproducer is now:

$ repoquery --refresh --releasever=37 --setopt=*.module_hotfixes=yes --repo=fedora-modular --whatrequires 'python(abi) = 3.10'  --whatrequires 'libpython3.10.so.1.0()(64bit)'
...
python3-aexpect-0:1.6.2-1.module_f37+14043+581035aa.noarch
python3-aexpect-0:1.6.2-1.module_f37+14045+986f5bf2.noarch
python3-avocado-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-glib-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-golang-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-loader-yaml-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-output-html-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-result-upload-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-resultsdb-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-cit-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-pict-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-yaml-to-mux-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-vt-0:82.0-3.module_f37+14076+b5a6614e.noarch
python3-avocado-vt-0:90.0-1.module_f37+14041+73823c5b.noarch
...

Comment 7 Cleber Rosa 2022-08-15 17:20:16 UTC
(In reply to Miro Hrončok from comment #5)
> Neither of the listed updates is for the modular avocado, hence it is not
> enough to close this bugzilla which is requesting the rebuild of modular
> avocado.

You are right, I missed the point about the modular repo.

Comment 8 Miro Hrončok 2022-09-01 07:29:18 UTC
Could you please rebuild this module or update this Bugzilla with some information (such as what it is blocked on or if there is a build failure...)? I'd be happy to assist with Python issues, but I don't know how to deal with modules.

Comment 9 Cleber Rosa 2022-09-01 23:57:21 UTC
(In reply to Miro Hrončok from comment #8)
> Could you please rebuild this module or update this Bugzilla with some
> information (such as what it is blocked on or if there is a build
> failure...)? I'd be happy to assist with Python issues, but I don't know how
> to deal with modules.

I have released a new upstream version from the 82lts branch, which will work under Python 3.11 (thus under F37 and rawhide).

https://avocado-framework.readthedocs.io/en/82lts/releases/lts/82_2.html#changes-from-82-1

And a PR for the Fedora package 82lts package branch:

https://src.fedoraproject.org/rpms/python-avocado/pull-request/32

I'm trying to get the modules to do a scratch build before posting the real updates.  I'll keep up posted.

Comment 11 Fedora Update System 2022-09-02 15:47:42 UTC
FEDORA-MODULAR-2022-e316278632 has been submitted as an update to Fedora 37 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-e316278632

Comment 12 Fedora Update System 2022-09-13 09:03:36 UTC
FEDORA-MODULAR-2022-e316278632 has been pushed to the Fedora 37 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-e316278632

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-09-21 01:38:32 UTC
FEDORA-MODULAR-2022-e316278632 has been pushed to the Fedora 37 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Miro Hrončok 2022-09-21 09:36:13 UTC
I still cannot verify this:

$ repoquery --refresh --releasever=37 --setopt=*.module_hotfixes=yes --repo={fedora-modular,updates{,-testing}-modular} --whatrequires 'python(abi) = 3.10'  --whatrequires 'libpython3.10.so.1.0()(64bit)' --latest=1
python3-aexpect-0:1.6.2-1.module_f37+14045+986f5bf2.noarch
python3-avocado-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-glib-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-golang-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-loader-yaml-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-output-html-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-result-upload-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-resultsdb-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-cit-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-pict-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-plugins-varianter-yaml-to-mux-0:82.0-4.module_f37+14045+986f5bf2.noarch
python3-avocado-vt-0:82.0-3.module_f37+14076+b5a6614e.noarch


Not sure what is going on. I think there are more streams fo this module and only one of them was fixed, is that correct? How do I tell?

Comment 15 Miro Hrončok 2022-09-21 13:35:56 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=2100819#c6

It appears that some of the packages were not rebuilt with Python 3.11. Back to the beginning.

Comment 16 Petr Pisar 2022-10-05 10:22:33 UTC
You are right, Miro.

These packages belong to avocado:82lts stream ("dnf module provides python3-aexpect-0:1.6.2-1.module_f37+14045+986f5bf2.noarch"). All finished module builds <https://mbs.fedoraproject.org/module-build-service/2/module-builds/?state=5&short=1&base_module_br_stream=f37&name=avocado&stream=82lts>. The latest module build <https://mbs.fedoraproject.org/module-build-service/2/module-builds/15370>. python-aexpect component was "Reused component from previous module build". Reused RPM build <https://koji.fedoraproject.org/koji/taskinfo?taskID=83830202> is from 2022-03-08.

Again, the module needs a complete rebuild using "all" rebuild strategy.

Comment 17 Petr Pisar 2022-10-05 10:28:22 UTC
I spawned a new rebuild <https://mbs.fedoraproject.org/module-build-service/2/module-builds/15474>.

Comment 18 Fedora Update System 2022-10-05 11:07:02 UTC
FEDORA-MODULAR-2022-96f40dded4 has been submitted as an update to Fedora 37 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-96f40dded4

Comment 19 Petr Pisar 2022-10-05 11:12:59 UTC
In comment #14 mentioned python3-avocado-vt-0:82.0-3.module_f37+14076+b5a6614e.noarch is from avocado-vt:82lts. Got to bug #2100819.

Comment 20 Kamil Páral 2022-10-06 08:55:20 UTC
Accepted as a freeze exception in https://pagure.io/fedora-qa/blocker-review/issue/953

Comment 21 Petr Pisar 2022-10-11 11:19:08 UTC
Stuck in pending-for-testing state. Escalated to reelengs <https://pagure.io/releng/issue/11080>.

Comment 22 Fedora Update System 2022-10-11 15:15:03 UTC
FEDORA-MODULAR-2022-96f40dded4 has been pushed to the Fedora 37 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-96f40dded4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Petr Pisar 2022-10-12 08:13:23 UTC
I forgot to rebuilding avocado:latest (python3-aexpect-1.6.2-1.module_f37+14043+581035aa.noarch).

Comment 24 Petr Pisar 2022-10-12 08:19:30 UTC
avocado:latest rebuild <https://mbs.fedoraproject.org/module-build-service/2/module-builds/15602> is running now.

Comment 25 Fedora Update System 2022-10-12 15:56:20 UTC
FEDORA-MODULAR-2022-96f40dded4 has been pushed to the Fedora 37 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-96f40dded4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 26 Petr Pisar 2022-10-14 07:47:12 UTC
I reopened a releng ticket to regenerate a testing repository <https://pagure.io/releng/issue/11080#comment-821325>. It is missing builds which should be there.

Comment 27 Fedora Update System 2022-10-24 17:54:50 UTC
FEDORA-MODULAR-2022-96f40dded4 has been pushed to the Fedora 37 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 28 Miro Hrončok 2022-10-25 10:49:15 UTC
I still see this:

$ repoquery --refresh --releasever=37 --setopt=*.module_hotfixes=yes --repo=fedora-modular --whatrequires 'python(abi) = 3.10'  --whatrequires 'libpython3.10.so.1.0()(64bit)' --latest=1
python3-aexpect-0:1.6.2-1.module_f37+14045+986f5bf2.noarch
python3-avocado-vt-0:82.0-3.module_f37+14076+b5a6614e.noarch

Comment 29 Petr Pisar 2022-10-25 11:18:28 UTC
Your problematic python3-aexpect-0:1.6.2-1.module_f37+14045+986f5bf2.noarch is from avocado:82lts:3720220902140108:9e842022:x86_64 in fedora-modular repository.

FEDORA-MODULAR-2022-96f40dded4 update pushed to stable delivers avocado-82lts-3720221005102421.9e842022 with newer python3-aexpect-1.6.2-1.module_f37+15474+befc9ed4.noarch. That build despite being tagged into f37-modular:

Mon Oct 24 19:54:30 2022 avocado-82lts-3720221005102421.9e842022 tagged into f37-modular by bodhi [still active]

is not in f37 modular stable repository, compose Fedora-37-20221024.n.0. That compose was made at Mon, 24 Oct 2022 11:54:02 GMT. That means the build was tagged into stable AFTER creating the compose.

I guess you need to wait another day for a new compose.

Comment 30 Petr Pisar 2022-10-26 10:17:20 UTC
According to my checks it is fixed in Fedora-37-20221025.n.0 compose.

Comment 31 Miro Hrončok 2022-10-26 10:44:03 UTC
Same for me:

$ repoquery --refresh --releasever=37 --setopt=*.module_hotfixes=yes --repo=fedora-modular --whatrequires 'python(abi) = 3.10'  --whatrequires 'libpython3.10.so.1.0()(64bit)'
(empty)

Thanks again Petr for fixing this!


Note You need to log in before you can comment on or make changes to this bug.