Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2101062 - firewalld was denied reading /sys/devices/system/cpu/possible when booting or restarting firewalld
Summary: firewalld was denied reading /sys/devices/system/cpu/possible when booting or...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 36
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2102538 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-25 03:24 UTC by Matt Fagnani
Modified: 2022-08-05 01:34 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-36.13-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-05 01:34:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-selinux selinux-policy pull 1260 0 None open Allow firewalld read the contents of the sysfs filesystem 2022-06-27 07:20:51 UTC

Description Matt Fagnani 2022-06-25 03:24:55 UTC
Description of problem:

firewalld was denied reading /sys/devices/system/cpu/possible when booting Fedora-KDE-Live-x86_64-Rawhide-20220624.n.1.iso downloaded from https://koji.fedoraproject.org/koji/buildinfo?buildID=1993562 

type=AVC msg=audit(1656139734.292:232): avc:  denied  { read } for  pid=1396 comm="firewalld" name="possible" dev="sysfs" ino=46 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file permissive=0

The same denial happened 3/3 times when I ran sudo systemctl restart firewalld

Version-Release number of selected component (if applicable):
selinux-policy-37.5-1.fc37.noarch
firewalld-1.1.1-2.fc37.noarch
kernel-5.19.0-0.rc3.20220623gitde5c208d533a.29.fc37.x86_64

How reproducible:
The denial happened on 2/2 boots and 3/3 times when restarting firewalld

Steps to Reproduce:
1. Boot Fedora-KDE-Live-x86_64-Rawhide-20220624.n.1.iso downloaded from https://koji.fedoraproject.org/koji/buildinfo?buildID=1993562 
2.
3.

Actual results:
firewalld was denied reading /sys/devices/system/cpu/possible when booting or restarting firewalld

Expected results:
No denials would happen.

Additional info:
firewalld still started successfully.

Comment 1 Fedora Update System 2022-06-30 07:25:55 UTC
FEDORA-2022-fd22b79a84 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-fd22b79a84

Comment 2 Zdenek Pytela 2022-06-30 08:20:24 UTC
*** Bug 2102538 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2022-07-01 02:09:53 UTC
FEDORA-2022-fd22b79a84 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-fd22b79a84`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-fd22b79a84

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2022-07-16 01:12:53 UTC
FEDORA-2022-320775eb9a has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-320775eb9a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-320775eb9a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-08-04 02:41:56 UTC
FEDORA-2022-139ec288ca has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-139ec288ca`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-139ec288ca

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-08-05 01:34:41 UTC
FEDORA-2022-139ec288ca has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.