Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2104044 - gnulib-0-44.20220212git.fc37 FTBFS: depends on removed i686 java-openjdk packages
Summary: gnulib-0-44.20220212git.fc37 FTBFS: depends on removed i686 java-openjdk pack...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnulib
Version: 37
Hardware: i686
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Mosaab Alzoubi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS F37FTBFS 2083750 2183558
TreeView+ depends on / blocked
 
Reported: 2022-07-05 14:46 UTC by jiri vanek
Modified: 2023-07-18 01:49 UTC (History)
11 users (show)

Fixed In Version: gnulib-0-47.20230709git.fc38 gnulib-0-47.20230709git.el9 gnulib-0-47.20230709git.el8 gnulib-0-47.20230709git.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-18 01:23:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description jiri vanek 2022-07-05 14:46:07 UTC
Dear maintainer, we are going to drop i686 java packages in f37 - https://fedoraproject.org/wiki/Changes/Drop_i686_JDKs
your package (or maybe jsut some subpackage)  is directly depending on java and is native.

Please take care, and adapt  your package to exclude java on i686. For  your convenience, there was added macro %{java_arches}, including all arches java is available on,  which you can use to ifarch-out java specific features out in i686 (on non-java arches). Although for plain java package, the change is as simple as https://src.fedoraproject.org/rpms/maven/c/520942645bfd1e4721dacd536a6ccbf80495a8ae?branch=rawhide, you can not use it. The ExclusiveArch: %{java_arches} is not going to work for you, because your package is not simple java application, and also non-java world depends on it.

See exemplar PR: https://src.fedoraproject.org/rpms/graphviz/pull-request/9#request_diff
See more details eg in:: https://bugzilla.redhat.com/show_bug.cgi?id=2102298
See why in : https://pagure.io/fesco/issue/2772
Please read carefully proposal: https://fedoraproject.org/wiki/Changes/Drop_i686_JDKs
Please see tracking bug for most up to date informations: https://bugzilla.redhat.com/show_bug.cgi?id=2083750

I'm terribly sorry to report this bug so late in f37 lifecycle. If you can, please handle this with priority.

Comment 1 Ben Cotton 2022-08-09 13:20:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 2 Petr Pisar 2023-04-18 11:41:41 UTC
*** Bug 2114533 has been marked as a duplicate of this bug. ***

Comment 3 Petr Pisar 2023-04-18 11:55:11 UTC
Mosaab, any progress in resolving this problem? I guess we need to disable the Java part of gnulib package on architectures where java-openjdk was removed. I could try it if you did not mind.

Comment 4 Petr Pisar 2023-04-18 12:36:23 UTC
Since gnulib-devel is noarch and Fedora does not have other Java compiler than java-devel (javac-java-17-openjdk), I propose moving "javaversion" gnulib module into an architecture-specific subpackage, on i686 keep the subpackage empty, and require the subackage from gnulib-devel.

If we can afford splitting javaversion from gnulib-devel without the (backward compatible) dependency, we could simply have no javaversion subpackage on i686.

Comment 5 Mosaab Alzoubi 2023-07-06 05:46:47 UTC
Working on it.

Comment 6 Fedora Update System 2023-07-06 18:19:13 UTC
FEDORA-2023-c193e7171c has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c193e7171c

Comment 7 Fedora Update System 2023-07-07 01:29:47 UTC
FEDORA-2023-c193e7171c has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c193e7171c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c193e7171c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-07-07 02:02:02 UTC
FEDORA-EPEL-2023-e5e251ea3d has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-e5e251ea3d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2023-07-07 03:06:49 UTC
FEDORA-2023-ce173a82f9 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-ce173a82f9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-ce173a82f9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-07-09 12:21:31 UTC
FEDORA-2023-730b82bd39 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-730b82bd39

Comment 11 Fedora Update System 2023-07-09 12:21:32 UTC
FEDORA-2023-1ebd33e0c1 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-1ebd33e0c1

Comment 12 Fedora Update System 2023-07-09 12:21:33 UTC
FEDORA-EPEL-2023-7159543bbd has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-7159543bbd

Comment 13 Fedora Update System 2023-07-10 01:10:49 UTC
FEDORA-2023-730b82bd39 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-730b82bd39`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-730b82bd39

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2023-07-10 01:16:37 UTC
FEDORA-EPEL-2023-0a9e760449 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-0a9e760449

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2023-07-10 01:22:49 UTC
FEDORA-EPEL-2023-7159543bbd has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-7159543bbd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2023-07-10 02:09:58 UTC
FEDORA-2023-1ebd33e0c1 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-1ebd33e0c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-1ebd33e0c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2023-07-18 01:23:58 UTC
FEDORA-2023-1ebd33e0c1 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2023-07-18 01:47:28 UTC
FEDORA-EPEL-2023-0a9e760449 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2023-07-18 01:49:10 UTC
FEDORA-EPEL-2023-7159543bbd has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2023-07-18 01:49:48 UTC
FEDORA-2023-730b82bd39 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.