Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2106899 - spyder-6.0.0a4 is available
Summary: spyder-6.0.0a4 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spyder
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2136710 2186052 2186056 2242026 2268682
Blocks: 2242941
TreeView+ depends on / blocked
 
Reported: 2022-07-13 19:57 UTC by Upstream Release Monitoring
Modified: 2024-03-30 01:56 UTC (History)
4 users (show)

Fixed In Version: spyder-6.0.0~a4-4.20240308gitv6.0.0a4.fc41 spyder-6.0.0~a4-4.20240308gitv6.0.0a4.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-26 16:42:29 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 6.0.0a1 (#2106899) (deleted)
2023-06-20 16:37 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a1 (#2106899) (deleted)
2023-07-18 22:13 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a1 (#2106899) (deleted)
2023-08-29 23:37 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a2 (#2106899) (deleted)
2023-09-05 22:00 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a2 (#2106899) (deleted)
2023-11-08 03:13 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a3 (#2106899) (deleted)
2023-12-19 03:44 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a3 (#2106899) (deleted)
2024-02-07 03:07 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a4 (#2106899) (deleted)
2024-03-13 02:04 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 6.0.0a4 (#2106899) (deleted)
2024-03-17 03:11 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2022-07-13 19:57:28 UTC
Releases retrieved: 5.3.2
Upstream release that is considered latest: 5.3.2
Current version/release in rawhide: 5.3.1-3.fc37
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 1 Upstream Release Monitoring 2022-07-13 19:57:35 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-zndivtj6/spyder.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./spyder-5.3.2_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2022-08-30 02:10:11 UTC
Releases retrieved: 5.3.3
Upstream release that is considered latest: 5.3.3
Current version/release in rawhide: 5.3.1-4.fc37
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 3 Upstream Release Monitoring 2022-08-30 02:10:18 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-5_0f8mco/spyder.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./spyder-5.3.3_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 4 Upstream Release Monitoring 2022-11-04 23:10:23 UTC
Releases retrieved: 5.4.0
Upstream release that is considered latest: 5.4.0
Current version/release in rawhide: 5.3.1-4.fc37
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 5 Upstream Release Monitoring 2022-11-04 23:10:30 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-qwq7k1ax/spyder.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./spyder-5.4.0_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 6 Upstream Release Monitoring 2022-12-30 02:14:55 UTC
Releases retrieved: 5.4.1
Upstream release that is considered latest: 5.4.1
Current version/release in rawhide: 5.3.1-4.fc37
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 7 Upstream Release Monitoring 2022-12-30 02:15:04 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-mtwgn9ky/spyder.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./spyder-5.4.1_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 8 Upstream Release Monitoring 2023-01-18 23:57:57 UTC
Releases retrieved: 5.4.2
Upstream release that is considered latest: 5.4.2
Current version/release in rawhide: 5.3.1-4.fc37
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 9 Upstream Release Monitoring 2023-01-18 23:58:05 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-rs7ssgae/spyder.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./spyder-5.4.2_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 10 hannes 2023-01-20 21:04:01 UTC
I am facing this issue using the latest spyder from the fedora repos. https://github.com/spyder-ide/spyder/issues/19862 
Is there a reason why the version is quite old in fedora? Should one install it via pip instead of dnf?

Comment 11 Mukundan Ragavan 2023-01-21 22:49:52 UTC
I am almost at the point of stepping away from spyder maintenance. There are new dependencies with new release and it is getting more difficult for me.

For 5.4.x, I need pytoolconfig and docstring_to_markdown packaged in Fedora. See my COPR where I started testing 5.4.x - https://copr.fedorainfracloud.org/coprs/nonamedotc/spyder/builds/



This is a long way of saying I have, sadly, not got around to updating spyder. :(

Comment 12 Upstream Release Monitoring 2023-04-05 03:03:28 UTC
Releases retrieved: 5.4.3
Upstream release that is considered latest: 5.4.3
Current version/release in rawhide: 5.3.1-6.fc38
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 13 Upstream Release Monitoring 2023-04-05 03:03:34 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-8uocl241/spyder.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./spyder-5.4.3_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 14 Upstream Release Monitoring 2023-06-20 16:37:26 UTC
Releases retrieved: 6.0.0a1
Upstream release that is considered latest: 6.0.0a1
Current version/release in rawhide: 5.3.1-6.fc38
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 15 Upstream Release Monitoring 2023-06-20 16:37:33 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-y16hldr8/spyder.spec']' returned non-zero exit status 1.

StdOut:
warning: %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)
setting SOURCE_DATE_EPOCH=1687219200
error: Bad file: ./spyder-6.0.0a1_relax_versions.patch: No such file or directory

RPM build warnings:
    %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)

RPM build errors:
    Bad file: ./spyder-6.0.0a1_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 16 Upstream Release Monitoring 2023-06-20 16:37:34 UTC
Created attachment 1971749 [details]
Update to 6.0.0a1 (#2106899)

Comment 17 Upstream Release Monitoring 2023-07-18 22:13:48 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-8p9aslcx/spyder.spec']' returned non-zero exit status 1.

StdOut:
warning: %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)
setting SOURCE_DATE_EPOCH=1689638400
error: Bad file: ./spyder-6.0.0a1_relax_versions.patch: No such file or directory

RPM build warnings:
    %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)

RPM build errors:
    Bad file: ./spyder-6.0.0a1_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 18 Upstream Release Monitoring 2023-07-18 22:13:50 UTC
Created attachment 1976412 [details]
Update to 6.0.0a1 (#2106899)

Comment 19 Fedora Admin user for bugzilla script actions 2023-08-16 12:57:44 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 20 Fedora Admin user for bugzilla script actions 2023-08-18 01:00:36 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 21 Upstream Release Monitoring 2023-08-29 23:37:28 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-r6i6kzeu/spyder.spec']' returned non-zero exit status 1.

StdOut:
warning: %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)
setting SOURCE_DATE_EPOCH=1693267200
error: Bad file: ./spyder-6.0.0a1_relax_versions.patch: No such file or directory

RPM build warnings:
    %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)

RPM build errors:
    Bad file: ./spyder-6.0.0a1_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 22 Upstream Release Monitoring 2023-08-29 23:37:29 UTC
Created attachment 1985987 [details]
Update to 6.0.0a1 (#2106899)

Comment 23 Upstream Release Monitoring 2023-09-05 22:00:16 UTC
Releases retrieved: 6.0.0a2
Upstream release that is considered latest: 6.0.0a2
Current version/release in rawhide: 5.3.1-8.fc39
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 24 Upstream Release Monitoring 2023-09-05 22:00:22 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-gaq2vitk/spyder.spec']' returned non-zero exit status 1.

StdOut:
warning: %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)
setting SOURCE_DATE_EPOCH=1693872000
error: Bad file: ./spyder-6.0.0a2_relax_versions.patch: No such file or directory

RPM build warnings:
    %patchN is deprecated (1 usages found), use %patch N (or %patch -P N)

RPM build errors:
    Bad file: ./spyder-6.0.0a2_relax_versions.patch: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 25 Upstream Release Monitoring 2023-09-05 22:00:23 UTC
Created attachment 1987148 [details]
Update to 6.0.0a2 (#2106899)

Comment 26 Sandro 2023-10-03 20:23:34 UTC
I'm working on this for rawhide only.

Comment 27 Upstream Release Monitoring 2023-11-08 03:13:36 UTC
Created attachment 1997778 [details]
Update to 6.0.0a2 (#2106899)

Comment 28 Upstream Release Monitoring 2023-11-08 03:19:39 UTC
the-new-hotness/release-monitoring.org's scratch build of spyder-6.0.0a2-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=108733909

Comment 29 Sandro 2023-11-08 10:09:13 UTC
Straight from the horse's mouth, upstream aims to release 6.x in three to four month. Right on schedule for F40. 🎉 I better go nudging some lawyer(s). ⚖️

https://github.com/spyder-ide/spyder/pull/21501#issuecomment-1800909349

Comment 30 Upstream Release Monitoring 2023-12-19 03:44:21 UTC
Releases retrieved: 6.0.0a3
Upstream release that is considered latest: 6.0.0a3
Current version/release in rawhide: 6.0.0~a1-11.20231010gitv6.0.0a1.fc40
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 31 Upstream Release Monitoring 2023-12-19 03:44:34 UTC
Created attachment 2004924 [details]
Update to 6.0.0a3 (#2106899)

Comment 32 Upstream Release Monitoring 2023-12-19 03:49:08 UTC
the-new-hotness/release-monitoring.org's scratch build of spyder-6.0.0a3-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=110538601

Comment 33 Upstream Release Monitoring 2024-02-07 03:07:34 UTC
Created attachment 2015526 [details]
Update to 6.0.0a3 (#2106899)

Comment 34 Upstream Release Monitoring 2024-02-07 03:10:06 UTC
the-new-hotness/release-monitoring.org's scratch build of spyder-6.0.0a3-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=113083806

Comment 35 Upstream Release Monitoring 2024-02-08 05:27:47 UTC
Releases retrieved: 6.0.0a4
Upstream release that is considered latest: 6.0.0a4
Current version/release in rawhide: 6.0.0~a1-17.20231010gitv6.0.0a1.fc40
URL: https://github.com/spyder-ide/spyder

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4874/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/spyder

Comment 36 Upstream Release Monitoring 2024-02-08 05:31:07 UTC
Scratch build failed. Details below:

GSSAPIAuthError: unable to obtain a session (gssapi auth failed: requests.exceptions.ReadTimeout: HTTPSConnectionPool(host='koji.fedoraproject.org', port=443): Read timed out. (read timeout=60))
Use following documentation to debug kerberos/gssapi auth issues. https://docs.pagure.org/koji/kerberos_gssapi_debug/
Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 249, in build
    session = self._session_maker()
              ^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 436, in _session_maker
    result = koji_session.gssapi_login(
             ^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3.11/site-packages/koji/__init__.py", line 2791, in gssapi_login
    raise GSSAPIAuthError(err)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 37 Upstream Release Monitoring 2024-03-13 02:04:49 UTC
Created attachment 2021359 [details]
Update to 6.0.0a4 (#2106899)

Comment 38 Upstream Release Monitoring 2024-03-13 02:09:35 UTC
the-new-hotness/release-monitoring.org's scratch build of spyder-6.0.0a4-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=114870804

Comment 39 Sandro 2024-03-13 08:05:20 UTC
It looks like Anitya might be confused. Version 6.0.0a4 was released Feb 8. I'm currently working on that in Copr[1]. It introduced yet another fresh dependency (superqt), which is up for review in bug 2268682, while pyuca (bug 2242026) is closing in on the finish line.

Today, we saw the arrival of Spyder 5.5.2[2]. We might want to look into updating F39 to that release.

[1] https://copr.fedorainfracloud.org/coprs/gui1ty/Spyder6/builds/
[2] https://github.com/spyder-ide/spyder/blob/master/changelogs/Spyder-5.md#version-552-2024-03-13

Comment 40 José Matos 2024-03-15 17:54:53 UTC
Either running alpha-1 (on F40) or alpha-4 from copr  the ipython console does not start.

It displays the following error:
An error occurred while starting the kernel
[SpyderKernelApp] WARNING | debugpy_stream undefined, debugging will not be enabled

Do you see this?

Comment 41 José Matos 2024-03-15 17:58:38 UTC
FWIW I will review the remaining dependencies. :-)

Comment 42 Sandro 2024-03-16 09:14:38 UTC
(In reply to José Matos from comment #40)
> Do you see this?

Yes, I do see it. Yet, I hadn't noticed before. So, thank you very much for the report. I opened bug 2269780 to investigate further.

(In reply to José Matos from comment #41)
> FWIW I will review the remaining dependencies. :-)

Thank you! Much appreciated.

Comment 43 Upstream Release Monitoring 2024-03-17 03:11:39 UTC
Created attachment 2022009 [details]
Update to 6.0.0a4 (#2106899)

Comment 44 Upstream Release Monitoring 2024-03-17 03:16:15 UTC
the-new-hotness/release-monitoring.org's scratch build of spyder-6.0.0a4-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=115055032

Comment 45 Sandro 2024-03-17 10:11:53 UTC
This is release monitoring trying to tell us that 5.5.3 has just been released. It carries only one bug fix, a script missing the executable bit.

Comment 46 Fedora Update System 2024-03-26 16:37:40 UTC
FEDORA-2024-343539e9cf (spyder-6.0.0~a4-4.20240308gitv6.0.0a4.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-343539e9cf

Comment 47 Fedora Update System 2024-03-26 16:42:29 UTC
FEDORA-2024-343539e9cf (spyder-6.0.0~a4-4.20240308gitv6.0.0a4.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 48 Fedora Update System 2024-03-26 17:17:28 UTC
FEDORA-2024-c552c1b9fd (python-cmap-0.2.0-1.fc40, python-pyconify-0.1.6-1.fc40, and 5 more) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-c552c1b9fd

Comment 49 Fedora Update System 2024-03-27 02:35:28 UTC
FEDORA-2024-c552c1b9fd has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf install --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-c552c1b9fd \*`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-c552c1b9fd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 50 Fedora Update System 2024-03-30 01:56:13 UTC
FEDORA-2024-c552c1b9fd (python-cmap-0.2.0-1.fc40, python-pyconify-0.1.6-1.fc40, and 5 more) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.