Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2107290 - Wined3d missing DLLs in 7.12-1.fc36
Summary: Wined3d missing DLLs in 7.12-1.fc36
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2107850 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-14 16:52 UTC by Davide Repetto
Modified: 2022-07-18 14:58 UTC (History)
5 users (show)

Fixed In Version: wine-7.12-2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-18 01:08:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Davide Repetto 2022-07-14 16:52:37 UTC
Description of problem:
=======================
On previously working prefixes now there are missing DLLs

[davide@dave ~]$ env WINEPREFIX="/home/davide/wine/Emulatori" /usr/bin/wine C:\\Program\ Files\ \(x86\)\\WinUAE\\winuae.exe 
002c:fixme:winediag:LdrInitializeThunk wine-staging 7.12 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
0104:err:module:import_dll Library libvkd3d-shader-1.dll (which is needed by L"C:\\windows\\system32\\wined3d.dll") not found
0104:err:module:import_dll Library libvkd3d-1.dll (which is needed by L"C:\\windows\\system32\\wined3d.dll") not found
0104:err:module:import_dll Library wined3d.dll (which is needed by L"C:\\windows\\system32\\d3d9.dll") not found
0104:err:module:import_dll Library d3d9.dll (which is needed by L"C:\\Program Files (x86)\\WinUAE\\winuae.exe") not found
0104:err:module:LdrInitializeThunk Importing dlls for L"C:\\Program Files (x86)\\WinUAE\\winuae.exe" failed, status c0000135


[davide@dave ~]$ env WINEPREFIX="/home/davide/wine/ReD" nice -n19 wine  "C:\Programmi\ZX Spectrum Emulator\zx32.exe"
0164:err:module:import_dll Library libvkd3d-shader-1.dll (which is needed by L"C:\\windows\\system32\\wined3d.dll") not found
0164:err:module:import_dll Library libvkd3d-1.dll (which is needed by L"C:\\windows\\system32\\wined3d.dll") not found
0164:err:module:import_dll Library wined3d.dll (which is needed by L"C:\\windows\\system32\\DDRAW.dll") not found
0164:err:module:import_dll Library DDRAW.dll (which is needed by L"C:\\Programmi\\ZX Spectrum Emulator\\zx32.exe") not found
0164:err:module:LdrInitializeThunk Importing dlls for L"C:\\Programmi\\ZX Spectrum Emulator\\zx32.exe" failed, status c0000135


wine-7.12-1.fc36.x86_64

Comment 1 zingale 2022-07-15 00:25:19 UTC
I have the same problem.  Things worked until this latest update.

Comment 2 Fedora Update System 2022-07-15 03:36:55 UTC
FEDORA-2022-f8f4823fb4 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f8f4823fb4

Comment 3 Fedora Update System 2022-07-16 01:12:11 UTC
FEDORA-2022-f8f4823fb4 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-f8f4823fb4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f8f4823fb4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Michael Cronenworth 2022-07-17 21:35:38 UTC
*** Bug 2107850 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2022-07-18 01:08:05 UTC
FEDORA-2022-f8f4823fb4 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 SP 2022-07-18 14:58:43 UTC
Thanks for the update.  The stock market program, Moomoo, now works as before.  But api-ms-win-core-versionansi-l1-1-1.dll - which is required be Adobe DNG Converter (v. x64.14.4) - is still missing.  Although there is a native Linux DNG converter it does not do quite the same job on RW2 files that the Adobe version does - but that is a separate discussion.


Note You need to log in before you can comment on or make changes to this bug.