Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2110372 - Request for kernel modules for DLN2
Summary: Request for kernel modules for DLN2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-25 10:56 UTC by Markus Rathgeb
Modified: 2022-09-07 06:28 UTC (History)
19 users (show)

Fixed In Version: kernel-5.19.4-200.fc36 kernel-5.19.4-100.fc35 kernel-5.19.6-300.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-28 23:05:32 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
integrate dln2 support into default fedora x86_64 config (deleted)
2022-07-28 07:27 UTC, Markus Rathgeb
no flags Details | Diff

Description Markus Rathgeb 2022-07-25 10:56:14 UTC
Description of problem:

I would like to use the Diolan DLN-2 hardware with my Fedora. The kernel driver for that hardware are available in the mainline kernel for a long time.
For Fedora the kernel modules are deactivated and AFAIK no available by any other package from the repository.

Would it be possible to enable support for the DLN2 kernel modules?

Diolan DLN2 support
modulename: dln2.ko
configname: CONFIG_MFD_DLN2

Diolan DLN-2 ADC driver support 
modulename: dln2-adc.ko
configname: CONFIG_DLN2_ADC

Diolan DLN2 GPIO support
modulename: gpio-dln2.ko
configname: CONFIG_GPIO_DLN2

Diolan DLN-2 USB I2C adapter
modulename: i2c-dln2.ko
configname: CONFIG_I2C_DLN2

Diolan DLN-2 USB SPI adapter
modulename: spi-dln2.ko
configname: CONFIG_SPI_DLN2

I do not know why this module has been disabled.
It is not listed in the "Forbidden items" (https://fedoraproject.org/wiki/Forbidden_items)

Version-Release number of selected component (if applicable):

---

How reproducible:

cat /boot/config-5.18.11-200.fc36.x86_64 | grep DLN2
# CONFIG_MFD_DLN2 is not set

dnf search dln2
Last metadata expiration check: 4 days, 5:03:27 ago on Thu 21 Jul 2022 07:50:24 AM CEST.
No matches found.

dnf search diolan
Last metadata expiration check: 4 days, 5:03:31 ago on Thu 21 Jul 2022 07:50:24 AM CEST.
No matches found.


Steps to Reproduce:
1. Plug in a DLN2
2. No driver is loaded
3. Device does not work (no i2c device)

Actual results:

Kernel driver missing


Expected results:

Kernel driver should be available (perhaps by a separate package).

Additional info:

https://diolan.com/dln-2

Comment 1 Markus Rathgeb 2022-07-28 07:27:18 UTC
Created attachment 1899868 [details]
integrate dln2 support into default fedora x86_64 config

This patch works for me.
I did it only for x86_64 (no other architecture) and fedora (no rhel).
The relevant modules will be added to the kernel-modules-extra package.

Comment 2 Markus Rathgeb 2022-08-22 10:52:02 UTC
Anything I can do to move this forward?

Comment 3 Fedora Update System 2022-08-25 22:07:10 UTC
FEDORA-2022-2a2290062f has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2a2290062f

Comment 4 Fedora Update System 2022-08-25 22:07:11 UTC
FEDORA-2022-b0205d1c7f has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b0205d1c7f

Comment 5 Fedora Update System 2022-08-25 22:07:12 UTC
FEDORA-2022-a7c12f917e has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a7c12f917e

Comment 6 Fedora Update System 2022-08-26 10:33:22 UTC
FEDORA-2022-2a2290062f has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-2a2290062f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-2a2290062f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-08-26 11:56:55 UTC
FEDORA-2022-b0205d1c7f has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-b0205d1c7f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b0205d1c7f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-08-26 12:45:04 UTC
FEDORA-2022-a7c12f917e has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a7c12f917e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a7c12f917e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-08-28 23:05:32 UTC
FEDORA-2022-b0205d1c7f has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-08-28 23:18:54 UTC
FEDORA-2022-a7c12f917e has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2022-09-02 08:26:48 UTC
FEDORA-2022-ccb0138bb6 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-ccb0138bb6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ccb0138bb6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-09-02 22:27:32 UTC
FEDORA-2022-ccb0138bb6 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Markus Rathgeb 2022-09-07 06:28:34 UTC
Tested with 5.19.6-200.fc36.x86_64:
* kernel-5.19.6-200.fc36.x86_64
* kernel-core-5.19.6-200.fc36.x86_64
* kernel-modules-5.19.6-200.fc36.x86_64
* kernel-modules-extra-5.19.6-200.fc36.x86_64

I was able to load the DLN2 modules - to be more precise the modules are loaded after plugging in the device.
I tested using the I²C device nodes (with i2c-dev module) to interact with devices connected to the DLN2's I²C bus.

All fine.

Thanks a lot!


Note You need to log in before you can comment on or make changes to this bug.