Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2110769 - Qt6 pkg-config files are not installed
Summary: Qt6 pkg-config files are not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt6
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Jan Grulich
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-25 20:26 UTC by Be
Modified: 2022-07-27 02:23 UTC (History)
2 users (show)

Fixed In Version: qt6-6.3.1-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-27 02:23:02 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Be 2022-07-25 20:26:23 UTC
Description of problem:
Qt6 packages only ship a single pkgconfig file, /usr/lib64/pkgconfig/Qt6.pc. The rest of the pkgconfig files for each of Qt's libraries are missing.

I have all qt6*-devel packages installed.

Version-Release number of selected component (if applicable):
6.3.0-1

How reproducible:
always

Steps to Reproduce:
1. sudo dnf install qt6*-devel
2. ls /usr/lib64/pkgconfig/Qt6*.pc

Actual results:
Only Qt6.pc is installed

Expected results:
Qt6.pc plus files for each of Qt's modules are installed (Qt6Core.pc, Qt6Gui.pc...)

Additional info:
Taking a look at the files installed by Arch's qt6 package (https://archlinux.org/packages/extra/x86_64/qt6-base/), I see the pkgconfig files should be there.

Comment 1 Be 2022-07-26 04:05:04 UTC
It turns out this was not implemented upstream until recently. https://codereview.qt-project.org/c/qt/qtbase/+/405678 was merged to the Qt 6.3 branch 2022-04-12. According to https://wiki.qt.io/Qt_6.3_Release Qt 6.3.0 was released 2022-04-12 and Qt 6.3.1 was released 2022-06-14, so pkgconfig file generation was first added in Qt 6.3.1. Fedora is currently shipping Qt 6.3.0. So I think the Qt6 packages need to be updated to resolve this.

Comment 2 Be 2022-07-26 04:13:16 UTC
Indeed, per the discussion on https://bugreports.qt.io/browse/QTBUG-86080 support for generating pkgconfig files was not merged for Qt 6.3.0 and was first released in Qt 6.3.1.

Comment 3 Jan Grulich 2022-07-26 06:31:49 UTC
Yes, it should be available in Qt 6.3.1 which I'm currently working on.

Comment 4 Fedora Update System 2022-07-26 10:38:35 UTC
FEDORA-2022-d1ac004bb1 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d1ac004bb1

Comment 5 Fedora Update System 2022-07-27 02:23:02 UTC
FEDORA-2022-d1ac004bb1 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.