Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2111003 - When a single contact is edited, it results in multiple contacts of the same name.
Summary: When a single contact is edited, it results in multiple contacts of the same ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-contacts
Version: 37
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F37FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-07-26 10:17 UTC by Lukas Ruzicka
Modified: 2022-09-19 00:19 UTC (History)
10 users (show)

Fixed In Version: gnome-contacts-43~rc-1.fc37 gnome-contacts-43~rc-3.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-19 00:19:04 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Three contacts after the one was edited. (deleted)
2022-07-26 10:17 UTC, Lukas Ruzicka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-contacts issues 248 0 None opened Duplicate contacts created after removing email address 2022-08-02 14:05:06 UTC

Description Lukas Ruzicka 2022-07-26 10:17:41 UTC
Created attachment 1899412 [details]
Three contacts after the one was edited.

Description of problem:

When a contact is edited in Gnome Contacts, another empty contact with the same name appears after the Done button is clicked. The original contact gets properly updated, the other one stays empty. Sometimes even two empty contacts appear.

Version-Release number of selected component (if applicable):
gnome-contacts-42.0-1.fc37.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Edit a contact and see the result.

Actual results:
Empty contacts appear while editing contacts.

Expected results:
No empty contacts appear and the application only edits the original
contact.

Additional info:
See the screenshot.

The upstream bug: https://gitlab.gnome.org/GNOME/gnome-contacts/-/issues/248

Comment 1 Fedora Blocker Bugs Application 2022-07-26 10:21:06 UTC
Proposed as a Blocker for 37-final by Fedora user lruzicka using the blocker tracking app because:

 Because this bug violates the basic functionality of the application, I propose this as a blocker.

Comment 2 Ben Cotton 2022-08-09 13:23:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 3 Adam Williamson 2022-08-22 15:56:43 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/838 , marking accepted.

Comment 4 Allan Day 2022-08-30 14:32:56 UTC
Contacts isn't heavily used, so it's unlikely that users will encounter this issue. The Workstation Working Group is of the opinion that it shouldn't block the release.

We're going to reassess the inclusion of gnome-contacts in the install media for F38. However, for now we think that it's best to give the app opportunity to improve and not block the release on it.

We are tracking this question here: https://pagure.io/fedora-workstation/issue/307

Comment 5 Adam Williamson 2022-08-30 18:40:21 UTC
Well, but now we're back at the problem from last cycle. The criteria, which we agreed between us, say:

"For all release-blocking desktop / arch combinations, the following applications must start successfully and withstand a basic functionality test: ... Additionally, for Fedora Workstation on the x86_64 architecture, all applications installed by default which can be launched from the Activities menu must meet this requirement". There's no distinction between "heavily used" and not heavily used apps there.

The feedback from 36 cycle was that we were finding bugs in less commonly used applications too late, so okay, this cycle, we tested them much earlier. We filed this bug last month. You still have another month and a half till the Final target date. This certainly seems early enough.

If you still don't want basic functionality bugs in "less heavily used" apps to be blockers even when they're discovered and reported in plenty of time, we need to change the criteria.

Comment 6 Tomas Popela 2022-08-31 05:16:11 UTC
Niels is working on this bug, but he said that it's not so simple and he had to basically rewrite all the internals - we might have something to test in the following days (probably a scratch build).

Comment 7 Niels De Graef 2022-09-01 01:58:59 UTC
Hi,

Just a quick update: I posted my almost ready branch on https://gitlab.gnome.org/GNOME/gnome-contacts/-/merge_requests/207 . The issue mentioned here (as well as some other issues) are now solved for my local setup.

(In reply to Adam Williamson from comment #5)
> The feedback from 36 cycle was that we were finding bugs in less commonly
> used applications too late, so okay, this cycle, we tested them much
> earlier. We filed this bug last month. You still have another month and a
> half till the Final target date. This certainly seems early enough.

Just wanted to make sure that this early testing is really, really appreciated here. Like Tomas already mentioned, properly fixing this was quite a bit of work, and this early testing definitely helped me make sure I had enough time to tackle this appropriately. So thank you!

Comment 8 Niels De Graef 2022-09-03 08:14:54 UTC
(In reply to Niels De Graef from comment #7)
> Hi,
> 
> Just a quick update: I posted my almost ready branch on
> https://gitlab.gnome.org/GNOME/gnome-contacts/-/merge_requests/207 . The
> issue mentioned here (as well as some other issues) are now solved for my
> local setup.

MR got merged

Comment 9 Niels De Graef 2022-09-06 15:05:01 UTC
Moved to POST since this is part of the .rc release

Comment 10 Fedora Update System 2022-09-07 08:12:50 UTC
FEDORA-2022-50e585b456 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-50e585b456

Comment 11 Fedora Update System 2022-09-08 09:32:21 UTC
FEDORA-2022-50e585b456 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-50e585b456`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-50e585b456

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Adam Williamson 2022-09-12 18:29:16 UTC
gnome-contacts was pulled from the update due to a crasher bug:
https://gitlab.gnome.org/GNOME/gnome-contacts/-/issues/266

so resetting this to POST to indicate we expect a new build/update to fix the crasher while also fixing this.

Comment 13 Fedora Update System 2022-09-14 14:32:22 UTC
FEDORA-2022-acbfee2ce8 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-acbfee2ce8

Comment 14 Fedora Update System 2022-09-15 01:48:51 UTC
FEDORA-2022-acbfee2ce8 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-acbfee2ce8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-acbfee2ce8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2022-09-19 00:19:04 UTC
FEDORA-2022-acbfee2ce8 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.