Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2113221 - fcitx-kkc: FTBFS in Fedora rawhide/f37
Summary: fcitx-kkc: FTBFS in Fedora rawhide/f37
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fcitx-kkc
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS F37FTBFS
TreeView+ depends on / blocked
 
Reported: 2022-08-01 23:27 UTC by Fedora Release Engineering
Modified: 2023-05-12 05:48 UTC (History)
2 users (show)

Fixed In Version: fcitx-kkc-0.1.4-6.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-12 05:48:53 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2022-08-01 23:27 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2022-08-01 23:27 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2022-08-01 23:27 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2022-08-01 23:27:11 UTC
fcitx-kkc failed to build from source in Fedora rawhide/f37

https://koji.fedoraproject.org/koji/taskinfo?taskID=89771949


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
Please fix fcitx-kkc at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
fcitx-kkc will be orphaned. Before branching of Fedora 38,
fcitx-kkc will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2022-08-01 23:27:13 UTC
Created attachment 1901100 [details]
build.log

Comment 2 Fedora Release Engineering 2022-08-01 23:27:14 UTC
Created attachment 1901101 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2022-08-01 23:27:16 UTC
Created attachment 1901102 [details]
state.log

Comment 4 Ben Cotton 2022-08-09 13:25:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 5 Jens Petersen 2023-05-12 05:43:10 UTC
I think this was caused by fcitx-qt5 deps breakage in F37 rawhide.

It would be worth retesting.

Comment 6 Jens Petersen 2023-05-12 05:48:05 UTC
Oh sorry confused by the "5", I guess fcitx is mostly deprecated now anyway in favor of fcitx5...


Note You need to log in before you can comment on or make changes to this bug.