Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2113469 - keylime-agent-rust: FTBFS in Fedora rawhide/f37
Summary: keylime-agent-rust: FTBFS in Fedora rawhide/f37
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: keylime-agent-rust
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS F40FTBFS F37FTBFS
TreeView+ depends on / blocked
 
Reported: 2022-08-01 23:51 UTC by Fedora Release Engineering
Modified: 2023-08-31 16:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-31 16:59:29 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2022-08-01 23:51 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2022-08-01 23:51 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2022-08-01 23:51 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2022-08-01 23:51:09 UTC
keylime-agent-rust failed to build from source in Fedora rawhide/f37

https://koji.fedoraproject.org/koji/taskinfo?taskID=89811270


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
Please fix keylime-agent-rust at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
keylime-agent-rust will be orphaned. Before branching of Fedora 38,
keylime-agent-rust will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2022-08-01 23:51:11 UTC
Created attachment 1901832 [details]
build.log

Comment 2 Fedora Release Engineering 2022-08-01 23:51:12 UTC
Created attachment 1901833 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2022-08-01 23:51:13 UTC
Created attachment 1901834 [details]
state.log

Comment 4 Fabio Valentini 2022-08-02 12:29:43 UTC
Caused by using unorthodox dependency restrictions for clap and clap_derive.
Should be fixed by using standard SemVer compatible version requirements.

Comment 5 Ben Cotton 2022-08-09 13:30:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.


Note You need to log in before you can comment on or make changes to this bug.