Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2114533 - gnulib: FTBFS in Fedora rawhide/f37: javac: command not found
Summary: gnulib: FTBFS in Fedora rawhide/f37: javac: command not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnulib
Version: 37
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mosaab Alzoubi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS F37FTBFS 2183558
TreeView+ depends on / blocked
 
Reported: 2022-08-02 19:39 UTC by Fedora Release Engineering
Modified: 2023-07-18 01:49 UTC (History)
4 users (show)

Fixed In Version: gnulib-0-47.20230709git.fc38 gnulib-0-47.20230709git.el9 gnulib-0-47.20230709git.el8 gnulib-0-47.20230709git.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-18 01:24:04 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2022-08-02 19:39 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2022-08-02 19:39 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2022-08-02 19:39 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2022-08-02 19:39:39 UTC
gnulib failed to build from source in Fedora rawhide/f37

https://koji.fedoraproject.org/koji/taskinfo?taskID=89783066


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
Please fix gnulib at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
gnulib will be orphaned. Before branching of Fedora 38,
gnulib will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2022-08-02 19:39:42 UTC
Created attachment 1903011 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2022-08-02 19:39:43 UTC
Created attachment 1903012 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2022-08-02 19:39:45 UTC
Created attachment 1903013 [details]
state.log

Comment 4 Ben Cotton 2022-08-09 13:35:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 5 Petr Pisar 2023-04-18 11:36:23 UTC
From an i668 build.log:

make[1]: Leaving directory '/builddir/build/BUILD/gnulib-9f48fb9/build-tests'
+ popd
~/build/BUILD/gnulib-9f48fb9
+ javac -d lib -source 11 -target 11 lib/javaversion.java
/var/tmp/rpm-tmp.ZirDsD: line 146: javac: command not found
error: Bad exit status from /var/tmp/rpm-tmp.ZirDsD (%build)

Comment 6 Petr Pisar 2023-04-18 11:40:26 UTC
From current i686 root.log:

DEBUG util.py:540:  Executing command: ['/usr/bin/systemd-nspawn', '-q', '-M', '128d855c93604f63b35bbaa0f315fe3b', '-D', '/var/lib/mock/f39-build-42349507-5146353-bootstrap/root', '-a', '--capability=cap_ipc_lock', '--bind=/tmp/mock-resolv.81_l5xnc:/etc/resolv.conf', '--console=pipe', '--setenv=TERM=vt100', '--setenv=SHELL=/bin/bash', '--setenv=HOME=/var/lib/mock/f39-build-42349507-5146353/root/installation-homedir', '--setenv=HOSTNAME=mock', '--setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin', '--setenv=PROMPT_COMMAND=printf "\\033]0;<mock-chroot>\\007"', '--setenv=PS1=<mock-chroot> \\s-\\v\\$ ', '--setenv=LANG=C.UTF-8', '--setenv=LC_MESSAGES=C.UTF-8', '--resolv-conf=off', '/usr/bin/dnf', 'builddep', '--installroot', '/var/lib/mock/f39-build-42349507-5146353/root/', '--setopt=install_weak_deps=0', '--disableplugin=local', '--disableplugin=spacewalk', '--disableplugin=versionlock', '/var/lib/mock/f39-build-42349507-5146353/root//builddir/build/SRPMS/gnulib-0-45.20220212git.fc39.src.rpm', '--setopt=tsflags=nocontexts'] with env {'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/var/lib/mock/f39-build-42349507-5146353/root/installation-homedir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'C.UTF-8', 'LC_MESSAGES': 'C.UTF-8', 'SYSTEMD_NSPAWN_TMPFS_TMP': '0', 'SYSTEMD_SECCOMP': '0'} and shell False
DEBUG util.py:443:  No matches found for the following disable plugin patterns: local, spacewalk, versionlock
DEBUG util.py:443:  No matching package to install: 'java-devel'
DEBUG util.py:443:  Not all dependencies satisfied
DEBUG util.py:443:  Error: Some packages could not be found.
DEBUG util.py:596:  Child return code was: 1

Comment 7 Petr Pisar 2023-04-18 11:41:41 UTC

*** This bug has been marked as a duplicate of bug 2104044 ***

Comment 8 Fedora Update System 2023-07-06 18:19:17 UTC
FEDORA-2023-ce173a82f9 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-ce173a82f9

Comment 9 Fedora Update System 2023-07-06 18:19:25 UTC
FEDORA-EPEL-2023-e5e251ea3d has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-e5e251ea3d

Comment 10 Fedora Update System 2023-07-06 18:19:31 UTC
FEDORA-2023-c193e7171c has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c193e7171c

Comment 11 Fedora Update System 2023-07-07 01:29:50 UTC
FEDORA-2023-c193e7171c has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c193e7171c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c193e7171c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-07-07 02:02:05 UTC
FEDORA-EPEL-2023-e5e251ea3d has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-e5e251ea3d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2023-07-07 03:06:52 UTC
FEDORA-2023-ce173a82f9 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-ce173a82f9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-ce173a82f9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2023-07-09 12:21:34 UTC
FEDORA-2023-730b82bd39 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-730b82bd39

Comment 15 Fedora Update System 2023-07-09 12:21:35 UTC
FEDORA-2023-1ebd33e0c1 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-1ebd33e0c1

Comment 16 Fedora Update System 2023-07-10 01:10:52 UTC
FEDORA-2023-730b82bd39 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-730b82bd39`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-730b82bd39

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2023-07-10 01:16:40 UTC
FEDORA-EPEL-2023-0a9e760449 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-0a9e760449

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2023-07-10 01:22:52 UTC
FEDORA-EPEL-2023-7159543bbd has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-7159543bbd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2023-07-10 02:10:01 UTC
FEDORA-2023-1ebd33e0c1 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-1ebd33e0c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-1ebd33e0c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2023-07-18 01:24:04 UTC
FEDORA-2023-1ebd33e0c1 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2023-07-18 01:47:30 UTC
FEDORA-EPEL-2023-0a9e760449 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2023-07-18 01:49:12 UTC
FEDORA-EPEL-2023-7159543bbd has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2023-07-18 01:49:51 UTC
FEDORA-2023-730b82bd39 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.