Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2115100 - Script '01_update_platforms_check.sh' FAILURE (exit code '1'). Continuing...
Summary: Script '01_update_platforms_check.sh' FAILURE (exit code '1'). Continuing...
Keywords:
Status: CLOSED DUPLICATE of bug 2170924
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: greenboot
Version: 9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Sayan
QA Contact:
URL:
Whiteboard:
Depends On: 2062455 2171154
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2022-08-03 20:16 UTC by Micah Abbott
Modified: 2023-03-02 16:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2062455
Environment:
Last Closed: 2023-03-02 16:34:04 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-130234 0 None None None 2022-08-03 20:18:50 UTC

Description Micah Abbott 2022-08-03 20:16:57 UTC
I'm observing this on a RHEL9 Edge installs, too

```
$ ssh -l core 192.168.122.228
Warning: Permanently added '192.168.122.228' (ED25519) to the list of known hosts.
Script '01_update_platforms_check.sh' FAILURE (exit code '1'). Continuing...
Boot Status is GREEN - Health Check SUCCESS
Last login: Wed Aug  3 16:13:53 2022 from 192.168.122.1
[core@miabbott-rhel9-edge-vm ~]$ rpm-ostree status
State: idle
Deployments:
● rhel-edge:rhel/9/x86_64/edge
                   Version: 9.0 (2022-08-03T15:57:40Z)
                    Commit: f4dc8ebd10ee208707849aed1bdc4739c1c8aba82fd8b044d56f4c3afdefc3a3
[core@miabbott-rhel9-edge-vm ~]$ rpm -q greenboot
greenboot-0.14.0-3.el9.x86_64
```

+++ This bug was initially created as a clone of Bug #2062455 +++

Description of problem:
After upgrading to latest F35, greenboot fails with following error:
"Script '01_update_platforms_check.sh' FAILURE (exit code '1'). Continuing..."


Version-Release number of selected component (if applicable):
Fedora-IoT-35-20220302.0 (any arch)
greenboot-0.14.0-1.fc35.aarch64
greenboot-default-health-checks-0.14.0-1.fc35.aarch64

How reproducible:
Every time

Steps to Reproduce:
1. Install version of Fedora-IoT-35-20220302.0 (any arch)
2. ssh into newly-installed IoT system
3. View greenboot failure upon ssh-ing in

Additional info:
See attached log

--- Additional comment from Paul Whalen on 2022-03-09 21:54:08 UTC ---

Running the script manually after log in works

bash /usr/lib/greenboot/check/wanted.d/01_update_platforms_check.sh
We can connect to all update platforms

--- Additional comment from Micah Abbott on 2022-08-03 20:15:35 UTC ---

I'm gonna clone this for RHEL because I'm seeing the same failure on RHEL9 Edge installs.

Comment 1 Micah Abbott 2023-03-02 16:34:04 UTC
Let's call this as a duplicate of 2170924

*** This bug has been marked as a duplicate of bug 2170924 ***


Note You need to log in before you can comment on or make changes to this bug.