Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2115757 - F37FailsToInstall: golang-github-lucas-clemente-quic-devel
Summary: F37FailsToInstall: golang-github-lucas-clemente-quic-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-lucas-clemente-quic
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall F37FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-08-05 09:26 UTC by Miro Hrončok
Modified: 2022-11-03 20:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-29 21:51:53 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-08-05 09:26:06 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (golang-github-lucas-clemente-quic) Fails To Install in Fedora 37:

can't install golang-github-lucas-clemente-quic-devel:
  - nothing provides golang(github.com/marten-seemann/qtls-go1-18) needed by golang-github-lucas-clemente-quic-devel-0.27.2-1.fc37.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --config-opts mirrored=False install golang-github-lucas-clemente-quic-devel


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Cotton 2022-08-09 13:35:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 2 Miro Hrončok 2022-08-14 17:12:50 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Major Hayden 🤠 2022-08-23 20:08:47 UTC
It looks like the latest version (0.28.1) is in git, but it just needs to be built for F38/F37. I ran a quick build with the spec that is in git and it built from source immediately.

I'm working on a package review that depends on this one, so I'm happy to help maintain this one if you'd like, Robert-André! 👋🏻

Comment 4 Major Hayden 🤠 2022-08-23 20:24:23 UTC
I sent through a scratch build and it looks good except for a single failing test on aarch64 that looks like it could be a race condition on slower hardware.

Build: https://koji.fedoraproject.org/koji/taskinfo?taskID=91185603

• Failure [0.306 seconds]
Server
/builddir/build/BUILD/quic-go-0.28.1/_build/src/github.com/lucas-clemente/quic-go/server_test.go:38
  server accepting connections that completed the handshake
  /builddir/build/BUILD/quic-go-0.28.1/_build/src/github.com/lucas-clemente/quic-go/server_test.go:181
    handling packets
    /builddir/build/BUILD/quic-go-0.28.1/_build/src/github.com/lucas-clemente/quic-go/server_test.go:202
      drops packets if the receive queue is full [It]
      /builddir/build/BUILD/quic-go-0.28.1/_build/src/github.com/lucas-clemente/quic-go/server_test.go:654
      Timed out after 0.100s.
      Expected
          <uint32>: 735
      to be equivalent to
          <int>: 1025
      /builddir/build/BUILD/quic-go-0.28.1/_build/src/github.com/lucas-clemente/quic-go/server_test.go:711

Comment 5 Mikel Olasagasti Uranga 2022-08-29 21:51:53 UTC
0.28.1 has been built for rawhide, f37 and f36 after skipping on test that fails randomly https://src.fedoraproject.org/rpms/golang-github-lucas-clemente-quic/pull-request/3


Note You need to log in before you can comment on or make changes to this bug.