Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2116032 - grub2-efi-1:2.06-45.fc36 chainloader broken
Summary: grub2-efi-1:2.06-45.fc36 chainloader broken
Keywords:
Status: CLOSED DUPLICATE of bug 2115202
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 36
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-08-06 11:18 UTC by Artemy Kapitula, Mail.Ru Cloud Solutions
Modified: 2022-08-08 20:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-08 20:30:01 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Artemy Kapitula, Mail.Ru Cloud Solutions 2022-08-06 11:18:13 UTC
Description of problem:

Chainloader broken on grub2-efi, Windows bootloader hung after being selected in GRUB2 chainloading. After downgrading to grub2-efi to 1:2.06-29.fc36 all works fine again

Version-Release number of selected component (if applicable):

1:2.06-45.fc36

After select Windows boot entry in grub menu, computer hung and no more activity perfromed.

Additional info:

GRUB installed on the same EFI partition where windows bootloader

# ls -l /boot/efi/EFI
drwx------ 2 root root 2048 июл 21 10:36 Boot
drwx------ 2 root root 2048 авг  6 13:56 fedora
drwx------ 4 root root 2048 дек 13  2021 Microsoft

Comment 1 Daniel Drake 2022-08-08 02:50:01 UTC
Duplicate of bug #2115202

Comment 2 Robbie Harwood 2022-08-08 20:30:01 UTC
Seems likely, yeah.

*** This bug has been marked as a duplicate of bug 2115202 ***


Note You need to log in before you can comment on or make changes to this bug.