Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2117065 - F37FailsToInstall: evolution-mapi
Summary: F37FailsToInstall: evolution-mapi
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-mapi
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2117420 (view as bug list)
Depends On:
Blocks: F38FailsToInstall F37FailsToInstall 2117210
TreeView+ depends on / blocked
 
Reported: 2022-08-09 22:02 UTC by Miro Hrončok
Modified: 2022-08-11 14:29 UTC (History)
2 users (show)

Fixed In Version: evolution-mapi-3.45.1-3.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-10 10:24:40 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-08-09 22:02:29 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (evolution-mapi) Fails To Install in Fedora 37:

can't install evolution-mapi:
  - nothing provides libndr.so.2()(64bit) needed by evolution-mapi-3.45.1-2.fc37.x86_64
  - nothing provides libndr.so.2(NDR_0.0.1)(64bit) needed by evolution-mapi-3.45.1-2.fc37.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --config-opts mirrored=False install evolution-mapi


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Milan Crha 2022-08-10 10:24:40 UTC
Well, it's not my fault that samba made an update and did not rebuild the dependencies. Adam is on this:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/BDMWVIRYDQS4UHZAT4X7XIPEKQ7GJM7P/

His evolution-mapi build failed on python dependency problems in one of the arches:
https://koji.fedoraproject.org/koji/taskinfo?taskID=90653424

No idea how these breakages can happen these days...

Comment 2 Milan Crha 2022-08-11 05:24:55 UTC
*** Bug 2117210 has been marked as a duplicate of this bug. ***

Comment 3 Milan Crha 2022-08-11 05:25:27 UTC
It is built now:
https://koji.fedoraproject.org/koji/buildinfo?buildID=2043663

Comment 4 Milan Crha 2022-08-11 05:31:50 UTC
*** Bug 2117420 has been marked as a duplicate of this bug. ***

Comment 5 Andreas Schneider 2022-08-11 14:29:26 UTC
I've added some protection to the Samba spec file so we detect it in future and will rebuild related packages in the side-tag too:

https://src.fedoraproject.org/rpms/samba/c/9c2239737959211cf9edbdb20666cd61b83e15a4?branch=rawhide


Note You need to log in before you can comment on or make changes to this bug.