Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2118152 - Screen blank and primary display options could not be changed
Summary: Screen blank and primary display options could not be changed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: GNOME SIG Unassigned
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker AcceptedFreezeException
: 2118956 2119952 (view as bug list)
Depends On:
Blocks: F37BetaFreezeException F37FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-08-14 16:20 UTC by K Naraian
Modified: 2022-09-05 13:31 UTC (History)
7 users (show)

Fixed In Version: gnome-control-center-43~beta-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-31 17:39:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-control-center issues 2025 0 None opened Screen Blank: value not preserved 2022-08-23 08:22:49 UTC

Description K Naraian 2022-08-14 16:20:21 UTC
Description of problem:
Screen blank option could not be changed. open gnome control center and go to power options, there try to change screen blank option and close the window. When re-open, the default option re-appears.

Version-Release number of selected component (if applicable):
F37 Pre-Release testing

How reproducible:
open gnome control center and go to power options, there try to change screen blank option and close the window. When re-open, the default option re-appears.

Steps to Reproduce:
1.
2.
3.

Actual results:
open gnome control center and go to power options, there try to change screen blank option and close the window. When re-open, the default option re-appears.

Expected results:
Changed option should be saved.

Additional info:

Comment 1 Fedora Blocker Bugs Application 2022-08-15 14:43:42 UTC
Proposed as a Blocker for 37-beta by Fedora user naraiank using the blocker tracking app because:

 ### CANDIDATE COMPOSE ###

== Blockers ==

Description of problem:
Screen blank option could not be changed. open gnome control center and go to power options, there try to change screen blank option and close the window. When re-open, the default option re-appears.

Version-Release number of selected component (if applicable):
F37 Pre-Release testing

How reproducible:
open gnome control center and go to power options, there try to change screen blank option and close the window. When re-open, the default option re-appears.

Steps to Reproduce:
1.
2.
3.

Actual results:
open gnome control center and go to power options, there try to change screen blank option and close the window. When re-open, the default option re-appears.

Expected results:
Changed option should be saved.

Additional info:

Comment 2 Kamil Páral 2022-08-16 09:57:54 UTC
I can confirm this with gnome-control-center-43~beta-1.fc37.x86_64. Not only "Screen Blank" changes are ignored, "Power Button Behavior" changes are ignored as well.

@knaraian Can you please file a bug upstream at https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues and link it here? Thanks!

Comment 3 Kamil Páral 2022-08-16 10:04:14 UTC
There is a workaround - you can set "Blank Screen Delay" from Privacy -> Screen, and that change is remembered. There seems to be no workaround for "Power Button Behavior", though.

Comment 4 Kamil Páral 2022-08-16 10:08:31 UTC
A blocker discussion ticket:
https://pagure.io/fedora-qa/blocker-review/issue/854

Comment 5 Adam Williamson 2022-08-22 15:58:52 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/854 , marking accepted.

Comment 6 Fedora Blocker Bugs Application 2022-08-22 17:17:46 UTC
Proposed as a Blocker for 37-beta by Fedora user naraiank using the blocker tracking app because:

 Standard operation.

Comment 7 Adam Williamson 2022-08-22 17:23:57 UTC
This is already accepted as a Final blocker, which is the point at which we block on things like this. There is no relevant criterion at Beta.

Comment 8 K Naraian 2022-08-22 18:51:42 UTC
(In reply to Kamil Páral from comment #2)
> I can confirm this with gnome-control-center-43~beta-1.fc37.x86_64. Not only
> "Screen Blank" changes are ignored, "Power Button Behavior" changes are
> ignored as well.
> 
> @knaraian Can you please file a bug upstream at
> https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues and link it
> here? Thanks!

Is it compulsory for me to open gnome ticket?

Comment 9 Kamil Páral 2022-08-23 08:22:50 UTC
(In reply to K Naraian from comment #8)
> Is it compulsory for me to open gnome ticket?

Nothing is compulsory for you in Fedora, so I don't really understand the question. But if you want to see it fixed, you need to report it to GNOME developers to their upstream tracker, they (mostly) don't follow Fedora bugs. So the best approach is to report it upstream, and if you want to propose it as a Fedora release blocker, then make a very short Bugzilla report here (just a link to the upstream ticket) a use it to propose the blocker.

But never mind, as this was accepted as a blocker, I wanted to report it upstream myself, and found the issue already present there. No further action needed.
https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2025

Comment 10 Alessio 2022-08-23 10:22:33 UTC
*** Bug 2119952 has been marked as a duplicate of this bug. ***

Comment 11 K Naraian 2022-08-23 14:42:56 UTC
(In reply to Kamil Páral from comment #9)
> (In reply to K Naraian from comment #8)
> > Is it compulsory for me to open gnome ticket?
> 
> Nothing is compulsory for you in Fedora, so I don't really understand the
> question. But if you want to see it fixed, you need to report it to GNOME
> developers to their upstream tracker, they (mostly) don't follow Fedora
> bugs. So the best approach is to report it upstream, and if you want to
> propose it as a Fedora release blocker, then make a very short Bugzilla
> report here (just a link to the upstream ticket) a use it to propose the
> blocker.
> 
> But never mind, as this was accepted as a blocker, I wanted to report it
> upstream myself, and found the issue already present there. No further
> action needed.
> https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2025

Thanks a lot. Any way thank you for letting me know how gnome bug tracker helps in resolving the issue. But I thought, the developer would have more stronger presence to the Gnome bugs tracker. Any how, I will try to escalate gnome issues to gnome bugs tracker, from next on..

Comment 12 Kamil Páral 2022-08-23 16:30:50 UTC
(In reply to Kamil Páral from comment #9)
> https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2025

Fixed in upstream repo.

Comment 13 Tomas Popela 2022-08-30 07:54:08 UTC
*** Bug 2118956 has been marked as a duplicate of this bug. ***

Comment 14 Adam Williamson 2022-08-30 15:51:36 UTC
Proposing as a Beta FE too, as this is annoying and affects live boot and first boot so can't be fixed fully with an update.

Technically speaking, these really were two separate bugs - they're just *similar*. But upstream decided to combine them so I guess we can too. :D

Comment 15 Fedora Update System 2022-08-30 19:51:35 UTC
FEDORA-2022-bf857cfff3 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-bf857cfff3

Comment 16 Fedora Update System 2022-08-31 02:22:12 UTC
FEDORA-2022-bf857cfff3 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-bf857cfff3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-bf857cfff3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Adam Williamson 2022-08-31 16:37:23 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/854 (the bot's count of +2 is because one comment is slightly misformatted), marking accepted Beta FE.

Comment 18 Fedora Update System 2022-08-31 17:39:39 UTC
FEDORA-2022-bf857cfff3 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Kamil Páral 2022-09-05 13:31:34 UTC
I verified that this is fixed with gnome-control-center-43~beta-2.fc37.x86_64


Note You need to log in before you can comment on or make changes to this bug.