Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2120970 - Error "Error interpreting JPEG image file (Backing store not supported)" in Eog
Summary: Error "Error interpreting JPEG image file (Backing store not supported)" in Eog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdk-pixbuf2
Version: 36
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-08-24 08:05 UTC by M. Merklinger
Modified: 2022-10-05 01:01 UTC (History)
5 users (show)

Fixed In Version: gdk-pixbuf2-2.42.9-2.fc37 gdk-pixbuf2-2.42.9-2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-03 00:19:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description M. Merklinger 2022-08-24 08:05:04 UTC
Description of problem: After upgrading gdk-pixbuf2 to version 2.42.9-1 some JPG images can't be loaded anymore. Eog gives the error message "Error interpreting JPEG image file (Backing store not supported)".


Version-Release number of selected component (if applicable): 2.42.9-1


How reproducible: Upgrade to version 2.42.9-1 of gdk-pixbuf2.


Steps to Reproduce:
1. Upgrade library to 2.42.9-1 of gdk-pixbuf2.
2. Download the JPG file in the linked issue below.
3. Open the image in Eog and receive error message.

Actual results: Eog shows the error message "Error interpreting JPEG image file (Backing store not supported)".


Expected results: Image opens correctly.


Additional info: It seems to be related to this issue https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/216

Comment 1 Jeremy Nickurak 2022-09-06 19:56:27 UTC
Worth noting that https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/216is marked fixed upstream as of a couple weeks ago, maybe needs a backport.

Comment 2 M. Merklinger 2022-09-20 18:11:41 UTC
I would really appreciate if we could get a backport for this bug. I can't open a lot of my image files and the background of my desktop is also black. Thank you!

Comment 3 Fedora Update System 2022-10-02 12:50:43 UTC
FEDORA-2022-48308bc2c4 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-48308bc2c4

Comment 4 Fedora Update System 2022-10-02 12:54:44 UTC
FEDORA-2022-162412af31 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-162412af31

Comment 5 Fedora Update System 2022-10-03 00:19:56 UTC
FEDORA-2022-162412af31 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2022-10-03 01:57:09 UTC
FEDORA-2022-48308bc2c4 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-48308bc2c4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-48308bc2c4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Rubén 2022-10-03 19:39:43 UTC
Now working. Thanks!

Comment 8 Fedora Update System 2022-10-05 01:01:24 UTC
FEDORA-2022-48308bc2c4 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.