Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2121710 - perl-XML-Parser:2.46 FTBFS: depends on EOLed perl-libwww-perl:6.48
Summary: perl-XML-Parser:2.46 FTBFS: depends on EOLed perl-libwww-perl:6.48
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: perl-XML-Parser
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact:
URL: https://pdc.fedoraproject.org/rest_ap...
Whiteboard:
Depends On:
Blocks: F38FTBFS
TreeView+ depends on / blocked
 
Reported: 2022-08-26 10:53 UTC by Petr Pisar
Modified: 2022-09-21 02:19 UTC (History)
2 users (show)

Fixed In Version: perl-XML-Parser:2.46:3820220906101447:17 perl-XML-Parser-2.46-3720220906101447.13 perl-XML-Parser-2.46-3620220906101447.9 perl-XML-Parser-2.46-3520220906101447.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-21 01:38:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2022-08-26 10:53:55 UTC
perl-XML-Parser:2.46 cannot be built for Fedora 38 because it depends on perl-libwww-perl:6.48 which is EOL:

Stream                 EOL
---------------------------------
perl-XML-Parser:2.46   2025-12-01
perl-libwww-perl:6.48  2022-06-01

Comment 1 Petr Pisar 2022-08-26 13:25:07 UTC
I tried to fix it, but MBS still reports "Problems were found during module dependency resolution: The module has conflicting buildrequires of: perl:5.32:3620220523110914:553f8e7a and perl:5.36:3620220819085903:f36". I reverted almost all my changes, but the error is still there. I will need to bisect the original YAML document because it looks like a bug in MBS.

Comment 2 Petr Pisar 2022-08-26 14:32:38 UTC
perl:5.32:3620220523110914:553f8e7a and perl:5.34:3620220822104650:f36

So the original, unmodified document also fails. I isolated it to this context:

            - context: '1'
              platform: f36
              buildrequires:
                  perl: ['5.32']
                  perl-libwww-perl: ['6.48']
              requires:
                  perl: ['5.32']
                  perl-libwww-perl: ['6.48']
              buildopts:
                  rpms:
                      macros: |
                          %_without_perl_Devel_CheckLib_enables_optional_test 1

These builds should satisfy it:

perl-libwww-perl:6.48:3620220303163539:81d42e4a (MBS#14003):
      perl: [5.32]
      perl-IO-Socket-SSL: [2.074]
      platform: [f36]
perl-IO-Socket-SSL:2.074:3620220302151456:3 (MBS#13973):
      perl: [5.32]
      platform: [f36]
perl:5.32:3620220523110914:553f8e7a (MBS#14503):
      platform: [f36]

But MBS insists on newer perl-IO-Socket-SSL:2.074:3620220729051354 which does have a context for perl:5.32. Just because it has the highest version. Hence the conflict. The latest perl-IO-Socket-SSL:2.074 does not have a context for perl:5.32 because its maintainer removed the context because it perl:5.32 was EOL.

A remedy is either reintroduce perl-IO-Socket-SSL:2.074 contexts for EOLed perl:5.32 to support reverse dependencies, or remove perl:5.32 contexts through out the system from all modules. I will coordinate with a perl module maintainer.

Comment 3 Petr Pisar 2022-08-26 14:34:02 UTC
newer perl-IO-Socket-SSL:2.074:3620220729051354 which does NOT have a context for perl:5.32

Comment 4 Petr Pisar 2022-08-29 14:56:35 UTC
I agreed with perl maintainer that we will contexts with all EOLed streams, we add contexts for all new streams, we deliver trough Bodhi a context for the latest stream.

Comment 5 Petr Pisar 2022-08-31 07:16:09 UTC
The resulting module defines 16 contexts and MBS is unable to process it <https://pagure.io/fedora-infrastructure/issue/10865>.

Comment 6 Petr Pisar 2022-09-06 13:47:25 UTC
I manged to build a context for each Fedora release. They use the latest, non-EOL stream of the dependencies.

Comment 7 Fedora Update System 2022-09-06 13:49:39 UTC
FEDORA-MODULAR-2022-cc44467a34 has been submitted as an update to Fedora 37 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-cc44467a34

Comment 8 Fedora Update System 2022-09-06 13:50:13 UTC
FEDORA-MODULAR-2022-df3b539029 has been submitted as an update to Fedora 36 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-df3b539029

Comment 9 Fedora Update System 2022-09-06 13:50:36 UTC
FEDORA-MODULAR-2022-6ef5bd51e4 has been submitted as an update to Fedora 35 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-6ef5bd51e4

Comment 10 Fedora Update System 2022-09-07 11:21:48 UTC
FEDORA-MODULAR-2022-df3b539029 has been pushed to the Fedora 36 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-df3b539029

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-09-07 11:30:28 UTC
FEDORA-MODULAR-2022-6ef5bd51e4 has been pushed to the Fedora 35 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-6ef5bd51e4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-09-13 09:03:38 UTC
FEDORA-MODULAR-2022-cc44467a34 has been pushed to the Fedora 37 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2022-cc44467a34

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-09-21 01:38:37 UTC
FEDORA-MODULAR-2022-cc44467a34 has been pushed to the Fedora 37 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2022-09-21 01:49:18 UTC
FEDORA-MODULAR-2022-df3b539029 has been pushed to the Fedora 36 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2022-09-21 02:19:31 UTC
FEDORA-MODULAR-2022-6ef5bd51e4 has been pushed to the Fedora 35 Modular stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.