Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2124281 - setup.cfg: entry_points keys are lowercased
Summary: setup.cfg: entry_points keys are lowercased
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: python-setuptools
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miro Hrončok
QA Contact: Lukáš Zachar
URL:
Whiteboard:
Depends On:
Blocks: 2047823
TreeView+ depends on / blocked
 
Reported: 2022-09-05 13:58 UTC by Miro Hrončok
Modified: 2023-05-09 10:14 UTC (History)
5 users (show)

Fixed In Version: python-setuptools-53.0.0-11.el9
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-09 08:14:17 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gitlab redhat/centos-stream/rpms python-setuptools merge_requests 9 0 None opened Draft: Fix case sensitivity of entry point names and keys in setup.cfg 2022-09-07 12:41:25 UTC
Red Hat Issue Tracker RHELPLAN-133241 0 None None None 2022-09-05 14:03:30 UTC
Red Hat Product Errata RHBA-2023:2460 0 None None None 2023-05-09 08:14:27 UTC

Description Miro Hrončok 2022-09-05 13:58:17 UTC
Description of problem:
See https://github.com/pypa/setuptools/issues/1937

I'd like to backport the fix for this:
https://github.com/pypa/setuptools/pull/2580


Version-Release number of selected component: 53.0.0-10.el9


Steps to Reproduce:
1. Try to build the ipython package from rawhide on epel9.
https://src.fedoraproject.org/rpms/ipython/tree/9473367fe84dc2a9a3371219ebf405acd2a8ef35

Actual results:
+ /usr/bin/python3 setup.py build '--executable=/usr/bin/python3 -s'            
running build                                                                   
running build_py                                                                
checking package data                                                           
Traceback (most recent call last):                                              
  File "/builddir/build/BUILD/ipython-8.0.1/setup.py", line 185, in <module>    
    setup(**setup_args)                                                         
  File "/usr/lib/python3.9/site-packages/setuptools/__init__.py", line 153, in
setup                        
    return distutils.core.setup(**attrs)                                        
  File "/usr/lib64/python3.9/distutils/core.py", line 148, in setup             
    dist.run_commands()                                                         
  File "/usr/lib64/python3.9/distutils/dist.py", line 966, in run_commands      
    self.run_command(cmd)                                                       
  File "/usr/lib64/python3.9/distutils/dist.py", line 985, in run_command       
    cmd_obj.run()                                                               
  File "/usr/lib64/python3.9/distutils/command/build.py", line 135, in run      
    self.run_command(cmd_name)                        
  File "/usr/lib64/python3.9/distutils/cmd.py", line 313, in run_command
    self.distribution.run_command(command)                                      
  File "/usr/lib64/python3.9/distutils/dist.py", line 985, in run_command       
    cmd_obj.run()
  File "/builddir/build/BUILD/ipython-8.0.1/setupbase.py", line 132, in run     
    check_package_data(self.package_data)                                       
  File "/builddir/build/BUILD/ipython-8.0.1/setupbase.py", line 120, in
check_package_data                  
    assert len(glob(path)) > 0, "No files match pattern %s" % path              
AssertionError: No files match pattern ipython/core/profile/README*             
error: Bad exit status from /var/tmp/rpm-tmp.6HcrAh (%build)                    
    Bad exit status from /var/tmp/rpm-tmp.6HcrAh (%build)

Expected results:
The build succeeds.

Additional info:

Technically, this might not be 100% backward compatible. Hence I'd like to reach an agreement before backporting it. 
https://src.fedoraproject.org/rpms/ipython/pull-request/43#comment-115177

Comment 1 Lumír Balhar 2022-09-05 14:11:17 UTC
Note that the failing function in IPython is some custom test checking that the package_data in setup.cfg is correctly defined. I think we don't need it and we can patch it out easily. https://github.com/ipython/ipython/blob/4396dd6207f5bb1c310ea897065c0c6e17d5f5b1/setupbase.py#L112-L122

But given that the fix is already implemented in setuptools for quite some time, backporting it is also a solution.

Comment 3 Miro Hrončok 2022-09-07 12:47:56 UTC
Tested by running the added test in %check (careful: tests are disabled by default).

Comment 4 Miro Hrončok 2022-09-07 12:58:25 UTC
Also verified that ipython from rawhide builds fine in epel9-next mock with this installed.

Comment 10 errata-xmlrpc 2023-05-09 08:14:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (python-setuptools bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:2460


Note You need to log in before you can comment on or make changes to this bug.