Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2124924 - Branch and build rav1e for EPEL 9
Summary: Branch and build rav1e for EPEL 9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-rav1e
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Lind
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2053866
TreeView+ depends on / blocked
 
Reported: 2022-09-07 13:33 UTC by Neal Gompa
Modified: 2022-11-16 02:53 UTC (History)
12 users (show)

Fixed In Version: rust-rav1e-0.5.1-5.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-16 02:53:01 UTC
Type: Task
Embargoed:


Attachments (Terms of Use)

Description Neal Gompa 2022-09-07 13:33:33 UTC
Please branch and build rust-rav1e in epel9.

If you do not wish to maintain rust-rav1e in epel9,
or do not think you will be able to do this in a timely manner,
the EPEL Packagers SIG would be happy to be a co-maintainer of the package;
please add the epel-packagers-sig group through
https://src.fedoraproject.org/rpms/rust-rav1e/addgroup
and grant it commit access, or collaborator access on epel* branches.

Comment 1 Fabio Valentini 2022-09-07 13:41:00 UTC
I can try to do this. But the Rust packages in EPEL9 are kind of in disrepair since Igor stopped merging updates from the Fedora branches. I'll look into figuring out what needs to be updated and/or added on EPEL9 for rav1e ... and I'll probably also need to figure out a list of Rust crates which I need to update in EPEL9 in when I update them in Fedora. Fun.

Comment 2 Neal Gompa 2022-09-07 20:14:49 UTC
There's plenty of time for this, I'm basically trying to prep for introducing ffmpeg into EPEL in November after RHEL 9.1 releases. So your help is greatly appreciated!

Comment 3 Maxwell G 2022-09-08 12:39:25 UTC
You'll probably have to start with updating rust-packaging in EPEL 9. It's currently rust-packaging-19-4.el9. The new rust2rpm generates "BuildRequires:  rust-packaging >= 21".

Comment 4 Fabio Valentini 2022-09-10 15:29:25 UTC
I can't update rust-packaging to v21+ on EPEL9 because rust-srpm-macros in RHEL 9 is stuck at v17.
Any idea what I can do about that?

Comment 5 Neal Gompa 2022-09-10 16:05:37 UTC
(In reply to Fabio Valentini from comment #4)
> I can't update rust-packaging to v21+ on EPEL9 because rust-srpm-macros in
> RHEL 9 is stuck at v17.
> Any idea what I can do about that?

Did we change the srpm macros between 17 to 21? If not, then it should work okay with some finagling. If so, then let's get it updated in CentOS Stream 9 and add some shims to epel-rpm-macros to deal with the difference until the update lands.

Comment 6 Fabio Valentini 2022-09-10 16:33:04 UTC
Hum. Looks like the macros in macros.rust-srpm haven't changed since 2019, so I think we should be fine.
I'll just need to relax the dependency in rust-packaging from = %{version} to >= 17.

Comment 7 Fabio Valentini 2022-09-10 16:54:17 UTC
Blergh. I can't update rust-packaging to match Fedora (v22) because that version started using match expressions, which were added with Python 3.10, and RHEL 9 "only" has Python 3.9. But I can update to v21 plus all the patches that we need, I think ...

Comment 8 Michel Lind 2022-11-03 20:21:06 UTC
For completeness, we do have rust-packaging 21 now (thanks Fabio!)

I'm doing a big update with 100+ new crates soon for bringing an unrelated project (retsnoop), will do some checks to see how many of those dependencies are shared with rav1e (i.e. computing the missing deps now, computing again after that update has landed and see how many we shaved off).

Comment 9 Michel Lind 2022-11-11 22:24:15 UTC
Taking this since I'm chomping through the dependencies now

Comment 10 Fedora Update System 2022-11-11 22:25:02 UTC
FEDORA-EPEL-2022-9c6ceed2c3 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-9c6ceed2c3

Comment 11 Fedora Update System 2022-11-13 03:04:48 UTC
FEDORA-EPEL-2022-9c6ceed2c3 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2022-11-15 22:28:16 UTC
FEDORA-EPEL-2022-40bb8ce9c5 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-40bb8ce9c5

Comment 13 Fedora Update System 2022-11-16 02:53:01 UTC
FEDORA-EPEL-2022-40bb8ce9c5 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.