Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2127746 - F38FailsToInstall: intel-igc-libs
Summary: F38FailsToInstall: intel-igc-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: intel-igc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: František Zatloukal
QA Contact: František Zatloukal
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-09-18 18:34 UTC by Miro Hrončok
Modified: 2022-11-29 13:01 UTC (History)
3 users (show)

Fixed In Version: intel-igc-1.0.12812.4-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-29 13:01:11 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-09-18 18:34:20 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (intel-igc) Fails To Install in Fedora 38:

can't install intel-igc-libs:
  - nothing provides libLLVMSPIRVLib.so.14()(64bit) needed by intel-igc-libs-1.0.12149-1.fc38.x86_64
  - nothing provides libopencl-clang.so.14()(64bit) needed by intel-igc-libs-1.0.12149-1.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install intel-igc-libs


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Brian Morrison 2022-09-22 18:02:40 UTC
Currently the -2 package build for F37 is failing too, apparently because the mock build is not using the clang-15.0 packages.

Comment 2 Miro Hrončok 2022-09-26 10:04:08 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Miro Hrončok 2022-10-17 11:01:35 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Brian Morrison 2022-10-17 11:43:08 UTC
This appears to be all part of difficulties with the intel package compilation, see here:

https://github.com/intel/intel-graphics-compiler/issues/258

until this is resolved it seems odd to be using the unmaintained packages process to deal with it.

Comment 5 Fedora Admin user for bugzilla script actions 2022-11-16 00:13:49 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 6 František Zatloukal 2022-11-16 00:20:15 UTC
This is now pending on https://github.com/intel/intel-graphics-compiler/issues/263 , work is in progress.

Comment 7 Fedora Update System 2022-11-29 12:59:36 UTC
FEDORA-2022-951f68a5b2 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-951f68a5b2

Comment 8 Fedora Update System 2022-11-29 13:01:11 UTC
FEDORA-2022-951f68a5b2 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.