Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2128674 - Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
Summary: Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires li...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: kronosnet-epel
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Davide Cavalca
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-21 11:26 UTC by Benedikt Steinbusch
Modified: 2022-09-30 02:39 UTC (History)
3 users (show)

Fixed In Version: kronosnet-epel-1.24-3.1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-30 02:39:57 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Benedikt Steinbusch 2022-09-21 11:26:23 UTC
Description of problem:
EL8 repositories now have libknet1-1.22-2.el8_6.x86_64, but kronosnet-epel depends on libknet1-1.22-1.el8.x86_64

Version-Release number of selected component (if applicable):
1.24-3.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 installed
2. Run dnf upgrade

Actual results:
Error: 
 Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.22-1.el8.x86_64
  - cannot install both libknet1-1.22-1.el8.x86_64 and libknet1-1.22-2.el8_6.x86_64
  - cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.22-1.el8.x86_64
  - cannot install the best update candidate for package libknet1-1.22-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Expected results:
Successful upgrade

Additional info:

Comment 1 Benedikt Steinbusch 2022-09-21 11:38:54 UTC
It might make sense to relax the Requires: clause to not depend on the exact version and release of libknet1.

Comment 2 Davide Cavalca 2022-09-21 15:16:10 UTC
So this is an interesting corner case. It looks like RHEL 8 put out a kronosnet-1.22-2.el8_6 build, per https://git.centos.org/rpms/kronosnet/c/2c21a86adf571665437e2779f1f618e0bffd6231?branch=c8, but there's no corresponding build in Koji (https://koji.mbox.centos.org/koji/packageinfo?packageID=874) and CentOS Stream 8 is at kronosnet-1.24-2.el8 (https://koji.mbox.centos.org/koji/buildinfo?buildID=22468). We already have a package tracking 1.24-2.el8 in the epel8-next branch for Stream, so I think I'll just need to make another epel8 build adjusting the dependency for RHEL 8. And then if/when RHEL 8 catches up to CentOS Stream 8, merge epel8-next into epel8 and do another build.

I don't think relaxing the Requires: would be appropriate as this package needs to be built from the exact same sources as the RHEL / CentOS Stream one to ensure compatibility.

Comment 3 Fedora Update System 2022-09-21 16:05:06 UTC
FEDORA-EPEL-2022-a7d574296e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-a7d574296e

Comment 4 Fedora Update System 2022-09-22 02:44:54 UTC
FEDORA-EPEL-2022-a7d574296e has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-a7d574296e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-09-30 02:39:57 UTC
FEDORA-EPEL-2022-a7d574296e has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.