Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2129860 - request epel 9 branch for libkml
Summary: request epel 9 branch for libkml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: libkml
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-26 13:13 UTC by Tom Rix
Modified: 2022-10-05 13:35 UTC (History)
2 users (show)

Fixed In Version: libkml-1.3.0-41.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-05 13:35:44 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tom Rix 2022-09-26 13:13:33 UTC
Description of problem:
gdal BuildRequires libkml
https://src.fedoraproject.org/rpms/gdal/blob/rawhide/f/gdal.spec
See line 88

libkml fails to build on epel9 because of unneeded mingw.
So disable the package mingw building.

 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
Merge PR
https://src.fedoraproject.org/rpms/libkml/pull-request/4

2.
3.

Actual results:
rawhide : https://koji.fedoraproject.org/koji/taskinfo?taskID=92349757
epel9   : https://koji.fedoraproject.org/koji/taskinfo?taskID=92336485


Expected results:


Additional info:
Add me to the project if you need help with epel

Comment 1 Fedora Update System 2022-09-27 06:31:02 UTC
FEDORA-EPEL-2022-02e3f12937 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-02e3f12937

Comment 2 Fedora Update System 2022-09-28 12:40:59 UTC
FEDORA-EPEL-2022-02e3f12937 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-02e3f12937

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-10-05 13:35:44 UTC
FEDORA-EPEL-2022-02e3f12937 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.