Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2130286 - Upgrading to Fedora 37 broke video acceleration - radeonsi
Summary: Upgrading to Fedora 37 broke video acceleration - radeonsi
Keywords:
Status: CLOSED DUPLICATE of bug 2123998
Alias: None
Product: Fedora
Classification: Fedora
Component: libva
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-27 17:28 UTC by Lyosha Alexeev
Modified: 2022-09-27 17:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-27 17:31:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Lyosha Alexeev 2022-09-27 17:28:35 UTC
After upgrading to Fedora 37, video acceleration stopped working.

$ LIBVA_DRIVER=radeonsi vainfo

libva info: VA-API version 1.15.0
libva info: Trying to open /usr/lib64/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_15
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.15 (libva 2.15.0)
vainfo: Driver version: Mesa Gallium driver 22.2.0 for AMD Radeon RX 580 Series (polaris10, LLVM 15.0.0, DRM 3.47, 5.19.11-300.fc37.x86_64)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc


mpv reports:

> [ffmpeg/video] h264: No support for codec h264 profile 100.

firefox (wayland):
> [GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found.

Version-Release number of selected component (if applicable):
libva-2.15.0-2.fc37.x86_64
kernel-5.19.11-300.fc37.x86_64
mesa-dri-drivers-22.2.0-3.fc37.x86_64

Additional info:
Worked fine on Fedora 36.

Comment 1 František Zatloukal 2022-09-27 17:31:17 UTC

*** This bug has been marked as a duplicate of bug 2123998 ***


Note You need to log in before you can comment on or make changes to this bug.