Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2131778 - latest build dropped subpackages breaking system updates
Summary: latest build dropped subpackages breaking system updates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F37FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-10-03 15:42 UTC by Dennis Gilmore
Modified: 2022-10-10 00:18 UTC (History)
6 users (show)

Fixed In Version: pipewire-0.3.59-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-10 00:18:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Dennis Gilmore 2022-10-03 15:42:19 UTC
Description of problem:

trying to update my system I can not because I happen to have pipewire-plugin-libcamera installed, and it was dropped from the most recent Fedora 36 and 37 builds. no steps were taken to obsolete and remove the dropped packages


Dependencies resolved.

 Problem 1: package pipewire-plugin-libcamera-0.3.58-3.fc37.aarch64 requires pipewire-libs(aarch-64) = 0.3.58-3.fc37, but none of the providers can be installed
  - cannot install both pipewire-libs-0.3.59-1.fc37.aarch64 and pipewire-libs-0.3.58-3.fc37.aarch64
  - cannot install the best update candidate for package pipewire-plugin-libcamera-0.3.58-3.fc37.aarch64
  - cannot install the best update candidate for package pipewire-libs-0.3.58-3.fc37.aarch64
 Problem 2: problem with installed package pipewire-plugin-libcamera-0.3.58-3.fc37.aarch64
  - package pipewire-plugin-libcamera-0.3.58-3.fc37.aarch64 requires pipewire-libs(aarch-64) = 0.3.58-3.fc37, but none of the providers can be installed
  - cannot install both pipewire-libs-0.3.59-1.fc37.aarch64 and pipewire-libs-0.3.58-3.fc37.aarch64
  - package pipewire-0.3.59-1.fc37.aarch64 requires pipewire-libs(aarch-64) = 0.3.59-1.fc37, but none of the providers can be installed
  - cannot install the best update candidate for package pipewire-0.3.58-3.fc37.aarch64
==============================================================================================================================================================================================================================================
 Package                                                   Architecture                                        Version                                                      Repository                                                   Size
==============================================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 pipewire-libs                                             aarch64                                             0.3.59-1.fc37                                                updates-testing                                             1.6 M
Skipping packages with broken dependencies:
 pipewire                                                  aarch64                                             0.3.59-1.fc37                                                updates-testing                                              46 k

Transaction Summary
==============================================================================================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2022-10-03 16:08:03 UTC
Proposed as a Freeze Exception for 37-final by Fedora user bcotton using the blocker tracking app because:

 pipewire-plugin-libcamera is not a default package, but breaking upgrades for people who have it installed is bad.

Comment 2 František Zatloukal 2022-10-03 17:35:10 UTC
Discussed during the 2022-10-03 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made:

"The decision to classify this bug as an "AcceptedFreezeException (Final)" was made as it is a noticeable issue that cannot be fixed with an update."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2022-10-03/f37-blocker-review.2022-10-03-16.00.log.txt

Comment 3 Wim Taymans 2022-10-04 07:25:49 UTC
The problem is that the libcamera package in fedora 37 is too old. Either:

1) upgrade libcamera to the f38 version.
2) try to patch up pipewire to work with the older one.

I would suggest to do 1) and then rebuild pipewire with the libcamera support again.

Comment 4 Fedora Update System 2022-10-04 21:46:46 UTC
FEDORA-2022-47e949c637 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-47e949c637

Comment 5 Geraldo Simião 2022-10-06 02:48:42 UTC
(In reply to Fedora Update System from comment #4)
> FEDORA-2022-47e949c637 has been submitted as an update to Fedora 37.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-47e949c637

This updates works fine, tested install with pipewire-plugin-libcamera and no conflicts.

Comment 6 Fedora Update System 2022-10-10 00:18:30 UTC
FEDORA-2022-47e949c637 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.