Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2134875 - Segfault when runnig with ldc-1.30
Summary: Segfault when runnig with ldc-1.30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tilix
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-10-14 14:03 UTC by Branislav Náter
Modified: 2023-03-21 03:09 UTC (History)
7 users (show)

Fixed In Version: tilix-1.9.5-9.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-21 03:09:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Branislav Náter 2022-10-14 14:03:20 UTC
Description of problem:
tilix will finish with segfault when running with latest ldc-1.30 library.
Discovered when running tilix-1.9.5-1.el9 from epel. After update from ldc-1.25 to ldc-libs-1.30, tilix starts to segfault.

Fabian (cc) mentioned that it builds (no error) but produced tilix binary just segfaults...

Steps to Reproduce:
1. start tilix on system with ldc-1.30

Actual results:
segfault

Expected results:
terminal is started

Comment 1 Branislav Náter 2022-10-14 14:37:07 UTC
Just small correction, tilix is not in epel, it's from Fabians repo [1]. It was rebuild using epel.

1. https://copr.fedorainfracloud.org/coprs/arrfab/not-in-epel9/

Comment 2 Kalev Lember 2022-10-14 17:38:04 UTC
Weird. It works just fine for me in F37 and F37 also uses ldc 1.30.

Comment 3 Fedora Update System 2022-12-05 19:05:14 UTC
FEDORA-EPEL-2022-e6dfec10b8 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-e6dfec10b8

Comment 4 Kalev Lember 2022-12-05 19:06:59 UTC
I got gtkd and tilix branched and built for EPEL 9 proper now. Could you test and see if the packages linked above work correctly? Thanks!

Comment 5 Fedora Update System 2022-12-06 02:38:20 UTC
FEDORA-EPEL-2022-e6dfec10b8 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-e6dfec10b8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Branislav Náter 2022-12-06 09:51:11 UTC
(In reply to Kalev Lember from comment #4)
> I got gtkd and tilix branched and built for EPEL 9 proper now. Could you
> test and see if the packages linked above work correctly? Thanks!

Hi, thanks for the effort. Unfortunately, still segfaulting. I've also updated my machine from rhel-9 nighlty compose to get the most recent packages but result is the same.

$ rpm -q tilix gtkd ldc-libs
tilix-1.9.5-5.el9.x86_64
gtkd-3.10.0-1.el9.x86_64
ldc-libs-1.30.0-2.el9
0 [bnater@localhost ~ ]$ tilix
Segmentation fault (core dumped)
139 [bnater@localhost ~ ]$

Comment 7 Kalev Lember 2022-12-06 21:16:02 UTC
Ah, bummer. I'll investigate this a bit but no promises as I am not really familiar with the D language or the compiler.

Weird that the exact same versions work just fine in Fedora though.

Comment 8 Fabian Arrotin 2022-12-07 11:08:25 UTC
yeah, as a workaround (I need it on my RHEL 9 professional laptop) I rebuilt it against previous version and that's the one I use for now : 
https://people.centos.org/arrfab/CentOS9/

Can't use copr as it's automatically pulling from epel9 and so back with the issue for ldc

Comment 9 Kalev Lember 2022-12-19 13:54:00 UTC
OK, I think I got this figured out. Before ldc 1.29, ldc was using ld.gold for linking but switched to just plain ld in 1.29, which is by default ld.bfd (using alternatives). It turns out that the older ld.bfd version in RHEL 8 and 9 somehow ends up linking gtkd wrong, which in turn leads to tilix crashing.

I've done some local tests and it looks like switching back to ld.gold for RHEL fixes this nicely.

Comment 10 Branislav Náter 2022-12-20 13:42:21 UTC
(In reply to Kalev Lember from comment #9)
> OK, I think I got this figured out. Before ldc 1.29, ldc was using ld.gold
> for linking but switched to just plain ld in 1.29, which is by default
> ld.bfd (using alternatives). It turns out that the older ld.bfd version in
> RHEL 8 and 9 somehow ends up linking gtkd wrong, which in turn leads to
> tilix crashing.
> 
> I've done some local tests and it looks like switching back to ld.gold for
> RHEL fixes this nicely.

Thanks for looking into this. Does that mean that new fixed build of "something" have to be done or some system configuration change? Thanks.

Comment 11 J.A. Norrid 2023-02-11 02:41:41 UTC
Have there been any updates on this? If not, would it be possible to at minimum, please share the configuration required to build and operate Tilix from source on RHEL 9.1 using current ldc or instructions for how to revert to ldc.gold? If I understand correctly this should be possible using alternatives? Thanks!

Comment 12 janderson@ciq.co 2023-02-13 23:43:14 UTC
My colleague J.A. Norrid above asked me if I had any thoughts on this. Thanks to the earlier pointer that the issue was resolved when using ld.gold, and that the issue was in gtkd, I used this procedure to build a working package:

update-alternatives --set ld /usr/bin/ld.gold
dnf download --enablerepo epel-testing-source --source gtkd
dnf builddep --enablerepo crb,epel-testing ./gtkd-3.10.0-1.el9.src.rpm
rpmbuild --rebuild ./gtkd-3.10.0-1.el9.src.rpm
dnf reinstall ~/rpmbuild/RPMS/aarch64/gtkd-3.10.0-1.el9.aarch64.rpm
rpmbuild --rebuild https://kojipkgs.fedoraproject.org//packages/tilix/1.9.5/8.fc38/src/tilix-1.9.5-8.fc38.src.rpm
dnf install ~/rpmbuild/RPMS/aarch64/tilix-1.9.5-8.el9.aarch64.rpm

Comment 13 Kalev Lember 2023-03-15 23:22:21 UTC
Sorry for the delay here.

I think I got this sorted out now and fixed the EPEL9 ldc package to use ld.gold, and rebuilt gtkd and tilix against the new version, which should hopefully resolve this.

Comment 14 Fedora Update System 2023-03-15 23:24:53 UTC
FEDORA-EPEL-2023-9502c4b907 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-9502c4b907

Comment 15 Fedora Update System 2023-03-16 19:12:45 UTC
FEDORA-EPEL-2023-9502c4b907 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-9502c4b907

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Branislav Náter 2023-03-20 14:31:46 UTC
(In reply to Kalev Lember from comment #13)
> Sorry for the delay here.
> 
> I think I got this sorted out now and fixed the EPEL9 ldc package to use
> ld.gold, and rebuilt gtkd and tilix against the new version, which should
> hopefully resolve this.

# rpm -q tilix gtkd ldc-libs
tilix-1.9.5-9.el9.x86_64
gtkd-3.10.0-4.el9.x86_64
ldc-libs-1.32.0-1.el9.x86_64

Works for me, many thanks!

Comment 17 Kalev Lember 2023-03-20 14:38:41 UTC
Great!

Comment 18 Fedora Update System 2023-03-21 03:09:30 UTC
FEDORA-EPEL-2023-9502c4b907 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.