Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2136148 - mock-core-configs install fails due to distribution-gpg-keys 1.77 dependency
Summary: mock-core-configs install fails due to distribution-gpg-keys 1.77 dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: distribution-gpg-keys
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-10-19 12:51 UTC by Amélie D
Modified: 2022-10-22 15:25 UTC (History)
5 users (show)

Fixed In Version: distribution-gpg-keys-1.78-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-22 15:25:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Amélie D 2022-10-19 12:51:21 UTC
Description of problem:
mock-core-configs 36.13 in epel7 cannot be installed, it requires distribution-gpg-keys >= 1.77, which does not exist in epel7.


Version-Release number of selected component (if applicable):
mock-core-configs-36.13-1.el7

How reproducible:
always

Steps to Reproduce:
1. yum install mock-core-configs
2.
3.

Actual results:
Error: Package: mock-core-configs-36.13-1.el7.noarch (epel)
           Requires: distribution-gpg-keys >= 1.77
           Available: distribution-gpg-keys-1.75-1.el7.noarch (epel)
               distribution-gpg-keys = 1.75-1.el7

Expected results:
successful installation

Additional info:

Comment 1 Pavel Raiskup 2022-10-20 07:38:33 UTC
Seems like we forgot to ship distribution-gpg-keys into EL7.  Thank you for the report.

Comment 2 Fedora Update System 2022-10-20 07:39:06 UTC
FEDORA-EPEL-2022-318362b0c0 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-318362b0c0

Comment 3 Fedora Update System 2022-10-20 15:43:26 UTC
FEDORA-EPEL-2022-318362b0c0 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-318362b0c0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 David Marshall 2022-10-21 17:23:39 UTC
Something odd happened along the way, because our internal mirror shows distribution-gpg-keys-1.76 showing up around 2022-08-20 and distribution-gpg-keys-1.77 showing up around 2022-09-05. Unfortunately, I don't have an indication of when these packages were no longer present in repodata.

Comment 5 Fedora Update System 2022-10-22 15:25:54 UTC
FEDORA-EPEL-2022-318362b0c0 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.