Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2136800 - openconnect fails due to missing symbol xmlIOFTPRead
Summary: openconnect fails due to missing symbol xmlIOFTPRead
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libxml2
Version: 37
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-10-21 11:26 UTC by Knut J BJuland
Modified: 2022-11-13 01:12 UTC (History)
11 users (show)

Fixed In Version: libxml2-2.10.3-1.fc36 libxml2-2.10.3-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-13 01:12:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 2138022 0 unspecified CLOSED Unable to start Scribus after running dnf upgrade 2022-11-10 09:37:48 UTC

Description Knut J BJuland 2022-10-21 11:26:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. sudo openconnect 

2.
3.

Actual results:
openconnect: symbol lookup error: /lib64/libxmlsec1.so.1: undefined symbol: xmlIOFTPRead, version LIBXML2_2.4.30


Expected results:
Should work and connect to vpn

Additional info:

Comment 2 Nikos Mavrogiannopoulos 2022-10-23 17:22:17 UTC
This is a libxml2 issue. It looks like a change in the ABI.

Comment 3 Loïc Yhuel 2022-10-24 08:53:48 UTC
libxml2 >= 2.10 disabled FTP by default : https://gitlab.gnome.org/GNOME/libxml2/-/commit/a0a0f3be93753e387e31e7de95904a24b3c876dd.

So either :
 - libxml2 must be built with "--with-ftp".
 - xmlsec1 (at least) must be rebuilt (it checks LIBXML_FTP_ENABLED).

Comment 4 David King 2022-10-24 09:06:49 UTC
Hi, and sorry, I only just saw this. Apologies for the unexpected ABI change. As FTP support is destined to be removed eventually, I would be in favour of rebuilding xmlsec1 and putting both that and libxml2 in the same Bodhi update. I am a provenpackager and can help out with this, of course., so I will get right on it.

Comment 5 Fedora Update System 2022-10-24 09:36:17 UTC
FEDORA-2022-a6812b0224 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a6812b0224

Comment 6 Fedora Update System 2022-10-24 10:56:37 UTC
FEDORA-2022-aeafd24818 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-aeafd24818

Comment 7 Fedora Update System 2022-10-24 10:57:08 UTC
FEDORA-2022-fcf5dbb447 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-fcf5dbb447

Comment 8 Fedora Update System 2022-10-24 11:13:53 UTC
FEDORA-2022-a6812b0224 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a6812b0224`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a6812b0224

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-10-24 14:13:51 UTC
FEDORA-2022-aeafd24818 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-aeafd24818`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-aeafd24818

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-10-24 14:19:49 UTC
FEDORA-2022-fcf5dbb447 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-fcf5dbb447`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-fcf5dbb447

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-10-25 13:13:17 UTC
FEDORA-2022-aeafd24818 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Petr Pisar 2022-11-01 09:01:48 UTC
This is not a proper fix because you break ABI in stable Fedoras. A proper fix is reenabling FTP support in stable Fedoras.

Comment 13 Petr Pisar 2022-11-01 09:03:58 UTC
$ ldd -r /usr/lib64/ImageMagick-6.9.12/modules-Q16/coders/url.so
[...]
undefined symbol: xmlNanoFTPInit, version LIBXML2_2.4.30        (/usr/lib64/ImageMagick-6.9.12/modules-Q16/coders/url.so)
undefined symbol: xmlNanoFTPClose, version LIBXML2_2.4.30       (/usr/lib64/ImageMagick-6.9.12/modules-Q16/coders/url.so)
undefined symbol: xmlNanoFTPGet, version LIBXML2_2.4.30 (/usr/lib64/ImageMagick-6.9.12/modules-Q16/coders/url.so)
undefined symbol: xmlNanoFTPNewCtxt, version LIBXML2_2.4.30     (/usr/lib64/ImageMagick-6.9.12/modules-Q16/coders/url.so)
undefined symbol: xmlNanoFTPConnect, version LIBXML2_2.4.30     (/usr/lib64/ImageMagick-6.9.12/modules-Q16/coders/url.so)

The same issue is with GraphicsMagick (bug #2138022).

Comment 14 Petr Pisar 2022-11-01 09:05:20 UTC
See the upstream change responsible for the break <https://gitlab.gnome.org/GNOME/libxml2/-/commit/a0a0f3be93753e387e31e7de95904a24b3c876dd>.

Comment 16 Fedora Update System 2022-11-01 14:46:58 UTC
FEDORA-2022-a6812b0224 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a6812b0224`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a6812b0224

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2022-11-04 08:54:48 UTC
FEDORA-2022-a6812b0224 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a6812b0224`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a6812b0224

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2022-11-04 10:55:40 UTC
FEDORA-2022-fcf5dbb447 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-fcf5dbb447`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-fcf5dbb447

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-11-13 01:12:37 UTC
FEDORA-2022-a6812b0224 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.