Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2137308 - F38FailsToInstall: elk, elk-mpich, elk-openmpi
Summary: F38FailsToInstall: elk, elk-mpich, elk-openmpi
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: elk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: marcindulak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2142304 2141137
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-10-24 12:22 UTC by Miro Hrončok
Modified: 2022-11-20 20:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-20 20:54:14 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-10-24 12:22:27 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (elk) Fails To Install in Fedora 38:

can't install elk:
  - nothing provides libxc.so.9()(64bit) needed by elk-8.3.22-2.fc37.x86_64
  - nothing provides libxcf90.so.9()(64bit) needed by elk-8.3.22-2.fc37.x86_64
  
can't install elk-mpich:
  - nothing provides libxc.so.9()(64bit) needed by elk-mpich-8.3.22-2.fc37.x86_64
  - nothing provides libxcf90.so.9()(64bit) needed by elk-mpich-8.3.22-2.fc37.x86_64
  
can't install elk-openmpi:
  - nothing provides libxc.so.9()(64bit) needed by elk-openmpi-8.3.22-2.fc37.x86_64
  - nothing provides libxcf90.so.9()(64bit) needed by elk-openmpi-8.3.22-2.fc37.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install elk elk-mpich elk-openmpi


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 marcindulak 2022-10-24 16:47:38 UTC
It looks related to this change in so version https://src.fedoraproject.org/rpms/libxc/c/926ea1b3e0b260f0240f0fbf9b1238309a4eb3d7?branch=rawhide.

Comment 2 marcindulak 2022-10-24 18:35:08 UTC
The latest elk is incompatible with libxc 6.0.0, see the log of a f38 build https://koji.fedoraproject.org/koji/taskinfo?taskID=93402801

```
Info(elk): current task :      0
Error(xcdata_libxc): incompatible Libxc version : 06.000.000
```

Reported upstream https://sourceforge.net/p/elk/discussion/897822/thread/6b18c3d2f1/

Comment 3 marcindulak 2022-11-03 21:12:19 UTC
Please don't push untested changes to the rawhide branch:  elk is not compatible with libxc 6.0.0.

If you are considering changes, please create a pull request and I'll review it.

Comment 4 Mamoru TASAKA 2022-11-04 00:06:35 UTC
I just saw this error, and checked devel list saying libxc update caused broken deps, and just tried rebuilding elk.
I am not the maintainer for libxc, I am just using provenpackager status to try to resolve unbroken deps.

Please consult the libxc maintainer then.

Comment 5 marcindulak 2022-11-08 22:18:06 UTC
It appears that allowing the version 6 in src/libxcifc.f90 would make the build proceed, however there is another, general issue with openmpi's mpiexec hanging on f38 #2141137, not related to libxc.

Comment 6 marcindulak 2022-11-19 22:50:45 UTC
This build https://koji.fedoraproject.org/koji/taskinfo?taskID=94273133 passes the test, despite i686 printing errors due to bug #2142304

Comment 7 Miro Hrončok 2022-11-20 20:54:14 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 38.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.