Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2138841 - F38FailsToInstall: golang-helm-3-devel
Summary: F38FailsToInstall: golang-helm-3-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-helm-3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Davide Cavalca
QA Contact:
URL:
Whiteboard:
Depends On: golang-github-oras-project-artifacts-spe golang-github-need-being-tree golang-oras golang-oras-2 2172236 2172237 2172238
Blocks: F38FailsToInstall F39FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-10-31 12:39 UTC by Miro Hrončok
Modified: 2023-02-23 02:19 UTC (History)
4 users (show)

Fixed In Version: golang-helm-3-3.11.1-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-22 00:07:56 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-10-31 12:39:41 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (golang-helm-3) Fails To Install in Fedora 38:

can't install golang-helm-3-devel:
  - nothing provides golang(github.com/docker/docker/pkg/term) needed by golang-helm-3-devel-3.5.4-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install golang-helm-3-devel


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-11-07 22:46:59 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Fedora Admin user for bugzilla script actions 2023-01-09 12:04:55 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Fedora Fails To Install 2023-01-10 21:10:21 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/golang-helm-3 by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 4 Fedora Admin user for bugzilla script actions 2023-01-12 00:12:47 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 5 Fedora Fails To Install 2023-01-12 15:54:05 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Davide Cavalca 2023-01-14 16:48:41 UTC
Planning to take another shot at fixing this over the weekend

Comment 7 blinxen 2023-02-04 13:35:56 UTC
@dcavalca What is the state of this package? Why is the build failing? Seeing that the build has been failing since last year and no real changes have been introduced, I would like to help fixing this package.

Comment 8 Davide Cavalca 2023-02-05 11:46:41 UTC
I have a fixed package already, it is waiting on the new version of oras being imported (see the linked bugs) before I can update it. I've filed https://pagure.io/fesco/issue/2950 to request an exception to the retirement policy.

Comment 9 Ben Cotton 2023-02-07 15:11:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 10 Fedora Update System 2023-02-22 00:06:21 UTC
FEDORA-2023-46c95e2c57 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-46c95e2c57

Comment 11 Fedora Update System 2023-02-22 00:07:56 UTC
FEDORA-2023-46c95e2c57 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2023-02-22 01:22:23 UTC
FEDORA-2023-4e2068ba5d has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-4e2068ba5d

Comment 13 Fedora Update System 2023-02-22 02:13:15 UTC
FEDORA-2023-c9b2182a4e has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c9b2182a4e

Comment 14 Fedora Update System 2023-02-22 02:52:53 UTC
FEDORA-2023-6550d9323b has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2023-6550d9323b

Comment 15 Fedora Update System 2023-02-22 11:25:05 UTC
FEDORA-2023-c9b2182a4e has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c9b2182a4e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c9b2182a4e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2023-02-22 11:44:19 UTC
FEDORA-2023-6550d9323b has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-6550d9323b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-6550d9323b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2023-02-22 13:32:14 UTC
FEDORA-2023-4e2068ba5d has been pushed to the Fedora 38 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-4e2068ba5d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2023-02-22 13:50:54 UTC
FEDORA-2023-4e2068ba5d has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-4e2068ba5d

Comment 19 Fedora Update System 2023-02-23 00:45:08 UTC
FEDORA-2023-4e2068ba5d has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2023-02-23 01:25:06 UTC
FEDORA-2023-6550d9323b has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2023-02-23 02:19:27 UTC
FEDORA-2023-c9b2182a4e has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.