Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2142051 - python-beanbag fails to build with pytest 7.2.0 - problem with dependency on `py` package
Summary: python-beanbag fails to build with pytest 7.2.0 - problem with dependency on ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-beanbag
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS 2137514
TreeView+ depends on / blocked
 
Reported: 2022-11-11 13:31 UTC by Lumír Balhar
Modified: 2023-08-03 06:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-03 06:07:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Lumír Balhar 2022-11-11 13:31:11 UTC
I'm testing an update of pytest to 7.2.0 and I've discovered that this package fails to build with it. The reason is a change related to `py` package.

`py` is an independent package developed by the same team as pytest and it has been bundled in pytest for quite some time. The `py` package itself is now in maintenance mode and pytest developers decided to bundle only a subset of its functionalities in pytest since version 7.2.0.

It seems that python-beanbag needs some parts of `py` that are no longer available in pytest (including deprecated `py.test` itself). There are two possible solutions:

1. Drop dependency on `py`. That requires some coordination with upstream but it's generally a good idea long-term.
2. Add python3-py to build dependencies. `py` package installed from python3-py will have a higher priority than py.py module bundled in pytest. This is a quick workaround but given the status of `py` project, it's only temporary.

If you want to, you can find the failed build in https://copr.fedorainfracloud.org/coprs/lbalhar/pytest/

Comment 1 Lumír Balhar 2022-11-11 16:01:03 UTC
I've reported the problem upstream but the project seems to be abandoned: https://github.com/ajtowns/beanbag/issues/15

Creating a patch or using sed to fix this should be easy.

Comment 3 Lumír Balhar 2022-11-23 12:20:40 UTC
Our plan is to ship the updated pytest during the next week. If you need any assistance from us, feel free to say so.

Comment 4 Ben Cotton 2023-02-07 14:58:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 5 Lumír Balhar 2023-08-03 06:07:51 UTC
This was fixed by the proposed PR and package now builds fine.


Note You need to log in before you can comment on or make changes to this bug.