Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2142192 - F38FailsToInstall: votca-libs
Summary: F38FailsToInstall: votca-libs
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libfabric
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2148956 (view as bug list)
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-11-11 23:33 UTC by Miro Hrončok
Modified: 2022-11-30 09:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-30 09:50:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github votca votca issues 1009 0 None open Rawhide builds time out 2022-11-21 16:32:18 UTC
Red Hat Bugzilla 2137312 0 unspecified CLOSED F38FailsToInstall: votca-libs 2022-11-21 16:28:45 UTC

Description Miro Hrončok 2022-11-11 23:33:47 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (votca) Fails To Install in Fedora 38:

can't install votca-libs:
  - nothing provides libxc.so.9()(64bit) needed by votca-libs-2022-8.fc37.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install votca-libs


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-11-20 20:54:28 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Christoph Junghans 2022-11-21 16:28:45 UTC
This is the same problem as in https://bugzilla.redhat.com/show_bug.cgi?id=2137312#c6, hinting at the a bug in libfaric https://bugzilla.redhat.com/show_bug.cgi?id=2137312#c7

One can very easily reproduce this:
$ docker run -it ghcr.io/votca/buildenv/fedora:rawhide /bin/bash
<in docker>
$ python3 -c "import espressomd"

f37b48de85b5:pid43.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid43: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[43]: (nic/PSM)[43]: PSM3 can't open nic unit: 0 (err=23)
f37b48de85b5:pid43.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid43: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[43]: (nic/PSM)[43]: PSM3 can't open nic unit: 0 (err=23)
f37b48de85b5:pid43.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid43: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[43]: (nic/PSM)[43]: PSM3 can't open nic unit: 0 (err=23)
f37b48de85b5:pid43.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid43: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[43]: (nic/PSM)[43]: PSM3 can't open nic unit: 0 (err=23)
--------------------------------------------------------------------------
Open MPI failed an OFI Libfabric library call (fi_endpoint).  This is highly
unusual; your job may behave unpredictably (and/or abort) after this.

  Local host: f37b48de85b5
  Location: mtl_ofi_component.c:512
  Error: Invalid argument (22)
--------------------------------------------------------------------------
[votca@f37b48de85b5 ~]$ python3 -c "import espressomd"
f37b48de85b5:pid50.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid50: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[50]: (nic/PSM)[50]: PSM3 can't open nic unit: 0 (err=23)
f37b48de85b5:pid50.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid50: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[50]: (nic/PSM)[50]: PSM3 can't open nic unit: 0 (err=23)
f37b48de85b5:pid50.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid50: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[50]: (nic/PSM)[50]: PSM3 can't open nic unit: 0 (err=23)
f37b48de85b5:pid50.python3: Failed to get eth0 (unit 0) cpu set
f37b48de85b5:pid50: PSM3 can't open nic unit: 0 (err=23)
PMIx Log Report:[50]: (nic/PSM)[50]: PSM3 can't open nic unit: 0 (err=23)
[f37b48de85b5:00051] [[3492,0],0] ORTE_ERROR_LOG: Out of resource in file util/show_help.c at line 501

which has nothing to do with the votca package nor espressomd.

Comment 3 Miro Hrončok 2022-11-21 17:13:07 UTC
If you change components like this, the automation will eventually close the bugzilla because libfabric installs fine. Let me remove the blocker here to prevent closing. A new bugzilla for vocta will be created -- please mark it as blocking this BZ instead of closing it as a duplicate.

Comment 4 Christoph Junghans 2022-11-21 18:49:42 UTC
The issue persists even with the fixed libfacbric package.

Comment 5 Christoph Junghans 2022-11-28 17:21:51 UTC
*** Bug 2148956 has been marked as a duplicate of this bug. ***

Comment 6 Christoph Junghans 2022-11-29 00:07:39 UTC
Another try: https://koji.fedoraproject.org/koji/taskinfo?taskID=94666610

Comment 7 Christoph Junghans 2022-11-29 00:20:35 UTC
Actually this one: https://koji.fedoraproject.org/koji/taskinfo?taskID=94667057

Comment 8 Miro Hrončok 2022-11-30 09:50:18 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 38.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.