Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2142342 - meld requires python3-gobject
Summary: meld requires python3-gobject
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: meld
Version: 37
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2153537 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-13 07:57 UTC by catch22
Modified: 2023-11-03 18:45 UTC (History)
6 users (show)

Fixed In Version: meld-3.22.0-5.fc37 meld-3.22.0-5.fc38 meld-3.22.0-5.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-02 01:04:49 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description catch22 2022-11-13 07:57:51 UTC
Description of problem:

Meld launches with errors, when looking for diffs in a git repo
"TypeError: Couldn't find foreign struct converter for 'cairo.Context'"

Version-Release number of selected component (if applicable):

Name         : meld
Version      : 3.22.0
Release      : 1.fc37
Architecture : noarch

How reproducible:
yes

Steps to Reproduce:
- toolbox create mytest_box
- toolbox enter mytest_box
- sudo dnf install meld git
- cd /tmp
- mkdir test_repo
- cd test_repo
- git init .
- touch some_file
- git add -A
- git commit -m "add some_file"
- echo "hi " >> some_file
- meld .



Actual results:

TypeError: Couldn't find foreign struct converter for 'cairo.Context'
TypeError: Couldn't find foreign struct converter for 'cairo.Context'
TypeError: Couldn't find foreign struct converter for 'cairo.Context'
TypeError: Couldn't find foreign struct converter for 'cairo.Context'
TypeError: Couldn't find foreign struct converter for 'cairo.Context'
TypeError: Couldn't find foreign struct converter for 'cairo.Context'



Expected results:
I should be able to click on the file in meld and see the differences.


Additional info:
This is fixed by adding the missing package dependency

sudo dnf install python3-gobject

Comment 1 Dominic Hopf 2023-09-07 14:37:40 UTC
*** Bug 2153537 has been marked as a duplicate of this bug. ***

Comment 2 Timothée Ravier 2023-10-23 16:49:57 UTC
Would be fixed by https://src.fedoraproject.org/rpms/meld/pull-request/4

Comment 3 Fedora Update System 2023-10-24 10:04:55 UTC
FEDORA-2023-dd9617cba8 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-dd9617cba8

Comment 4 Fedora Update System 2023-10-24 10:05:00 UTC
FEDORA-2023-4954d667ab has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-4954d667ab

Comment 5 Fedora Update System 2023-10-25 02:19:24 UTC
FEDORA-2023-4954d667ab has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-4954d667ab`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-4954d667ab

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2023-10-25 02:29:27 UTC
FEDORA-2023-af4c237a4f has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-af4c237a4f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-af4c237a4f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2023-10-25 02:52:58 UTC
FEDORA-2023-dd9617cba8 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-dd9617cba8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-dd9617cba8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-11-02 01:04:49 UTC
FEDORA-2023-4954d667ab has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2023-11-02 02:34:20 UTC
FEDORA-2023-af4c237a4f has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2023-11-03 18:45:20 UTC
FEDORA-2023-dd9617cba8 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.