Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2142602 - Missing dependency for python3-idle on python3-test
Summary: Missing dependency for python3-idle on python3-test
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3.10
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2142224 2142696 2148181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-14 14:59 UTC by qoheniac
Modified: 2022-12-01 01:38 UTC (History)
10 users (show)

Fixed In Version: python3.10-3.10.8-3.fc38 python3.10-3.10.8-3.fc36 python3.10-3.10.8-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-12-01 01:38:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description qoheniac 2022-11-14 14:59:29 UTC
Description of problem:
Installing IDLE doesn't install the test package.

Version-Release number of selected component (if applicable):
3.10.8

How reproducible:
Uninstall IDLE and the test package if installed, install IDLE and try to run it.

Steps to Reproduce:
1. sudo dnf rm python3-{idle,test}
2. sudo dnf in python3-idle
3. idle

Actual results:
Traceback (most recent call last):
  File "/usr/bin/idle", line 3, in <module>
    from idlelib.pyshell import main
  File "/usr/lib64/python3.10/idlelib/pyshell.py", line 53, in <module>
    from idlelib import debugger
  File "/usr/lib64/python3.10/idlelib/debugger.py", line 7, in <module>
    from idlelib import macosx
  File "/usr/lib64/python3.10/idlelib/macosx.py", line 7, in <module>
    from test.support import requires, ResourceDenied
ModuleNotFoundError: No module named 'test.support'

Expected results:
IDLE does not crash.

Additional info:
Workaround: sudo dnf in python3-test

Comment 1 Miro Hrončok 2022-11-14 15:06:29 UTC
I've looked at the code and the test.support import is conditional on the idlelib.testing boolean. That should always be False when you run idle and the import should never happen :/

Comment 2 Miro Hrončok 2022-11-14 15:08:10 UTC
But I can reproduce this on Fedora 35 with python3-idle-3.10.8-2.fc35.x86_64

Comment 3 Miro Hrončok 2022-11-14 15:10:00 UTC
Oh I see, it's a regression, fixed in https://github.com/python/cpython/commit/928b5f1bdeb4f9ab243ccfdf0aa0ca52839974f9

Comment 5 Fedora Update System 2022-11-14 23:29:59 UTC
FEDORA-2022-bb119e4197 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-bb119e4197

Comment 6 Fedora Update System 2022-11-14 23:34:40 UTC
FEDORA-2022-bb119e4197 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2022-11-14 23:40:26 UTC
FEDORA-2022-a7cad6bd22 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a7cad6bd22

Comment 8 Miro Hrončok 2022-11-14 23:42:15 UTC
*** Bug 2142696 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2022-11-15 00:58:10 UTC
FEDORA-2022-462f39dd2f has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-462f39dd2f

Comment 10 Fedora Update System 2022-11-15 02:34:57 UTC
FEDORA-2022-a7cad6bd22 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a7cad6bd22`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a7cad6bd22

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-11-15 09:17:09 UTC
FEDORA-2022-f44dd1bec2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f44dd1bec2

Comment 12 Fedora Update System 2022-11-16 01:23:04 UTC
FEDORA-2022-462f39dd2f has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-462f39dd2f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-462f39dd2f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-11-16 01:35:58 UTC
FEDORA-2022-f44dd1bec2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-f44dd1bec2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f44dd1bec2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2022-11-22 01:19:33 UTC
FEDORA-2022-462f39dd2f has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2022-11-23 01:16:04 UTC
FEDORA-2022-a7cad6bd22 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Miro Hrončok 2022-11-23 13:16:38 UTC
*** Bug 2142224 has been marked as a duplicate of this bug. ***

Comment 17 Petr Viktorin (pviktori) 2022-11-24 14:31:17 UTC
*** Bug 2148181 has been marked as a duplicate of this bug. ***

Comment 18 Fedora Update System 2022-12-01 01:38:17 UTC
FEDORA-2022-f44dd1bec2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.