Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2143030 - moodle-4.0.5-1.fc37.noarch has file conflicts with php-google-apiclient
Summary: moodle-4.0.5-1.fc37.noarch has file conflicts with php-google-apiclient
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: moodle
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-15 20:33 UTC by stan
Modified: 2022-11-25 02:38 UTC (History)
4 users (show)

Fixed In Version: moodle-4.0.5-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-25 02:38:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description stan 2022-11-15 20:33:24 UTC
Description of problem:
When trying to update moodle in F37 using dnf, I get file conflict errors.

Version-Release number of selected component (if applicable):
moodle-4.0.5-1.fc37.noarch

How reproducible:
every time

Steps to Reproduce:
1.  Have moodle and php-google-apiclient installed
2.  Try to update to moodle-4.0.5-1.fc37.noarch
3.

Actual results:
r: Transaction test error:
file /var/www/moodle/web/lib/google/src/Google/Http/REST.php from install of moodle-4.0.5-1.fc37.noarch conflicts with file from package php-google-apiclient1-1.1.7-14.fc36.noarch
file /var/www/moodle/web/lib/google/src/Google/IO/Curl.php from install of moodle-4.0.5-1.fc37.noarch conflicts with file from package php-google-apiclient1-1.1.7-14.fc36.noarch
file /var/www/moodle/web/lib/google/src/Google/IO/Stream.php from install of moodle-4.0.5-1.fc37.noarch conflicts with file from package php-google-apiclient1-1.1.7-14.fc36.noarch
file /var/www/moodle/web/lib/google/src/Google/Signer/P12.php from install of moodle-4.0.5-1.fc37.noarch conflicts with file from package php-google-apiclient1-1.1.7-14.fc36.noarch
file /var/www/moodle/web/lib/google/src/Google/Verifier/Pem.php from install of moodle-4.0.5-1.fc37.noarch conflicts with file from package php-google-apiclient1-1.1.7-14.fc36.noarch

Expected results:
moodle updates

Additional info:

I don't know which package is at fault, but it was a moodle update that triggered the file conflict, so I posted the bug to moodle.

Not about moodle, but this kind of error is easily prevented.  rpm has two options, -q and --filesbypkg that lists all the files in a package.  If the file names (with path) for every fedora package were put in a database as primary key, the build system would only have to get the package list, run some sequel queries against all the file names possible, and ensure that there wasn't a conflict before pushing the package to testing.  Since it seems so obvious, I am guessing that it needs someone knowledgeable of the packaging application to implement it, fingers on the keyboard.  I suppose because it happens so infrequently, it isn't worth the effort.

Comment 1 Gwyn Ciesla 2022-11-16 17:38:45 UTC
This is due to the retirement of php-google-apiclient1 in f38, and re-bundling of the Moodle-shipped version. Removing php-google-apiclient1 should resolve this. I'll push an update with a fix.

Comment 2 Fedora Update System 2022-11-16 18:21:41 UTC
FEDORA-2022-d5e433a1b4 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d5e433a1b4

Comment 3 stan 2022-11-16 20:31:15 UTC
I removed php-google-apiclient1, and it pulled moodle 4.0.4 as a dependency.  I was then able to install the moodle 4.0.5 version without complaint.  Thank you.

Comment 4 Fedora Update System 2022-11-17 02:39:36 UTC
FEDORA-2022-d5e433a1b4 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-d5e433a1b4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d5e433a1b4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-11-25 02:38:51 UTC
FEDORA-2022-d5e433a1b4 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.