Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2143488 - The Bluetooth adapter name isn't the same device name set in Settings > About
Summary: The Bluetooth adapter name isn't the same device name set in Settings > About
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gopal krishna tiwari
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-17 02:33 UTC by h2d2fyzt
Modified: 2022-12-03 01:42 UTC (History)
5 users (show)

Fixed In Version: bluez-5.66-4.fc37 bluez-5.66-4.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-29 01:10:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Incorrect device name (deleted)
2022-11-17 02:33 UTC, h2d2fyzt
no flags Details

Description h2d2fyzt 2022-11-17 02:33:07 UTC
Created attachment 1924869 [details]
Incorrect device name

Created attachment 1924869 [details]
Incorrect device name

Created attachment 1924869 [details]
Incorrect device name

Description of problem:
According to Bastian Nocera in these issues:

- https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1786#note_1448321
- https://bugzilla.gnome.org/show_bug.cgi?id=658154#c5

...the device name used for bluetooth should sync with the device name set in System > About (hostname) if the distribution installs bluetoothd properly. In Fedora, the bluetooth device name in Fedora is always "BlueZ [version]".

In the issue https://pagure.io/fedora-workstation/issue/335#comment-824940, Bastian theorized that the problem could be in bluetoothd.

Version-Release number of selected component (if applicable):
bluez-5.65-3.fc37.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Go to Settings;
2. Check the hostname in the About page;
3. Check the device name in the Bluetooth page.

Actual results:
The device name used for Bluetooth isn't the device name set in the About page. The bluetooth device name is "BlueZ [version]".

Expected results:
The Bluetooth device name and the hostname being the same.

Additional info:
I found this. It might be useful: https://wiki.polaire.nl/doku.php?id=fedora_25_bluez_change_hostname

Comment 1 Peter Robinson 2022-11-17 10:56:19 UTC
I'm not sure what you're asking here, looking at 3 of my machines running with bluetooth they're reporting as their hostname and not as "bluez <version>".

Comment 2 Bastien Nocera 2022-11-17 11:23:06 UTC
(In reply to Peter Robinson from comment #1)
> I'm not sure what you're asking here, looking at 3 of my machines running
> with bluetooth they're reporting as their hostname and not as "bluez
> <version>".

I sent patches for the bug upstream. It is buggy on new installations, see the patches.

Not sure why the original reporter filed a bug here when it's already being worked on upstream.

Comment 3 Peter Robinson 2022-11-17 11:55:42 UTC
Bastion can you link to the patches?

Comment 4 Peter Robinson 2022-11-17 12:02:21 UTC
> Not sure why the original reporter filed a bug here when it's already being
> worked on upstream.

Well I suspect that's because you said on the upstream bug "You need to ask your OS provider to install bluetoothd properly" and hence the problem has come here, but the problem isn't actually a problem with the "OS provider" but an upstream bug in the tools that is exposed on Fedora.

Comment 5 Bastien Nocera 2022-11-17 12:47:36 UTC
(In reply to Peter Robinson from comment #4)
> > Not sure why the original reporter filed a bug here when it's already being
> > worked on upstream.
> 
> Well I suspect that's because you said on the upstream bug "You need to ask
> your OS provider to install bluetoothd properly" and hence the problem has
> come here, but the problem isn't actually a problem with the "OS provider"
> but an upstream bug in the tools that is exposed on Fedora.

You're quoting an answer to somebody else's request from months ago, not the discussion with the reporter which happened on a fedora-workstation issue.

(In reply to Peter Robinson from comment #3)
> Bastion can you link to the patches?

They've been merged upstream:
https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=e515f4b6e25c971c47ab79e9cbdfa17119bbde23
https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=e2b2b1675f310023862319ea10ffd205a75cc0cb

Comment 6 Bastien Nocera 2022-11-17 12:50:45 UTC
GNOME infra is down, so that's going to free up some time to cherry-pick those patches.

Comment 7 Fedora Update System 2022-11-17 14:10:13 UTC
FEDORA-2022-aa9141f45f has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-aa9141f45f

Comment 8 Fedora Update System 2022-11-17 14:10:39 UTC
FEDORA-2022-4b6d66c74b has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-4b6d66c74b

Comment 9 h2d2fyzt 2022-11-18 01:27:23 UTC
(In reply to Bastien Nocera from comment #2)
> (In reply to Peter Robinson from comment #1)
> > I'm not sure what you're asking here, looking at 3 of my machines running
> > with bluetooth they're reporting as their hostname and not as "bluez
> > <version>".
> 
> I sent patches for the bug upstream. It is buggy on new installations, see
> the patches.
> 
> Not sure why the original reporter filed a bug here when it's already being
> worked on upstream.

I was a bit confused in the Fedora Pagure issue whether I should still report the problem or not.

Comment 10 Fedora Update System 2022-11-18 01:57:19 UTC
FEDORA-2022-4b6d66c74b has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-4b6d66c74b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-4b6d66c74b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-11-18 02:44:32 UTC
FEDORA-2022-aa9141f45f has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-aa9141f45f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-aa9141f45f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-11-29 01:10:53 UTC
FEDORA-2022-aa9141f45f has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2022-12-03 01:42:05 UTC
FEDORA-2022-4b6d66c74b has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.