Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2144660 - Please build OpenSceneGraph for EPEL 9
Summary: Please build OpenSceneGraph for EPEL 9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: OpenSceneGraph
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2118473 2147357 2147360 2147366
Blocks: EPELPackagersSIG 2144650
TreeView+ depends on / blocked
 
Reported: 2022-11-21 23:50 UTC by Robert Scheck
Modified: 2022-12-08 01:10 UTC (History)
2 users (show)

Fixed In Version: OpenSceneGraph-3.6.5-12.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-12-08 01:10:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Robert Scheck 2022-11-21 23:50:44 UTC
Please branch and build OpenSceneGraph in epel9.

If you do not wish to maintain OpenSceneGraph in epel9, or do not think you will be able to do this in a timely manner, the EPEL Packagers SIG would be happy to be a co-maintainer of the package; please add the epel-packagers-sig group through
https://src.fedoraproject.org/rpms/OpenSceneGraph/addgroup and grant it commit access, or collaborator access on epel* branches.

Comment 1 Robert Scheck 2022-11-21 23:52:12 UTC
No matching package to install: 'Coin4-devel'
No matching package to install: 'liblas-devel'
No matching package to install: 'mingw32-cairo'
No matching package to install: 'mingw32-curl'
No matching package to install: 'mingw32-gdal'
No matching package to install: 'mingw32-gstreamer1'
No matching package to install: 'mingw32-jasper'
No matching package to install: 'mingw32-librsvg2'
No matching package to install: 'mingw32-libtiff'
No matching package to install: 'mingw32-libxml2'
No matching package to install: 'mingw32-openal-soft'
No matching package to install: 'mingw32-openexr'
No matching package to install: 'mingw32-poppler-glib'
No matching package to install: 'mingw64-cairo'
No matching package to install: 'mingw64-curl'
No matching package to install: 'mingw64-gdal'
No matching package to install: 'mingw64-gstreamer1'
No matching package to install: 'mingw64-jasper'
No matching package to install: 'mingw64-librsvg2'
No matching package to install: 'mingw64-libtiff'
No matching package to install: 'mingw64-libxml2'
No matching package to install: 'mingw64-openal-soft'
No matching package to install: 'mingw64-openexr'
No matching package to install: 'mingw64-poppler-glib'
No matching package to install: 'wxGTK-devel'

From my understanding, the mingw32/64 dependencies and packages could be disabled for EPEL 9. For Coin4-devel, liblas-devel and wxGTK-devel, I didn't investigate yet.

Comment 2 Robert Scheck 2022-11-23 21:06:21 UTC
For me, a rebuild of OpenSceneGraph-3.6.5-11.fc38 worked after (solving the build-time dependencies and) applying https://src.fedoraproject.org/rpms/OpenSceneGraph/pull-request/4

Comment 3 Robert Scheck 2022-11-29 06:32:49 UTC
Will you be able to branch and build OpenSceneGraph in epel9? The EPEL Packagers SIG would be happy to be a co-maintainer if you do not wish to build it on epel9.

Comment 4 Fedora Update System 2022-11-29 20:12:31 UTC
FEDORA-EPEL-2022-ed783c2160 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-ed783c2160

Comment 5 Fedora Update System 2022-11-30 01:43:44 UTC
FEDORA-EPEL-2022-ed783c2160 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-ed783c2160

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-12-08 01:10:54 UTC
FEDORA-EPEL-2022-ed783c2160 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.