Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2148633 - python-geoplot: FTBFS in Fedora Rawhide (and all branches)
Summary: python-geoplot: FTBFS in Fedora Rawhide (and all branches)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-geoplot
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS F35FTBFS F36FTBFS F37FTBFS
TreeView+ depends on / blocked
 
Reported: 2022-11-26 15:42 UTC by Ben Beasley
Modified: 2023-02-20 03:46 UTC (History)
2 users (show)

Fixed In Version: python-geoplot-0.5.1-5.fc39 python-geoplot-0.5.1-5.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-20 03:40:04 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ResidentMario geoplot issues 283 0 None open Tests fail with geopandas 0.11 2022-11-26 22:11:36 UTC

Description Ben Beasley 2022-11-26 15:42:41 UTC
Description of problem:
Package python-geoplot fails to build from source in Fedora Rawhide (and all branches).

Version-Release number of selected component (if applicable):
0.5.1-3.fc37

Steps to Reproduce:
koji build --scratch f38 python-geoplot-0.5.1-3.fc37.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-geoplot

=================================== FAILURES ===================================
_______________________ TestClip.test_clip_init_default ________________________

self = <mixin_tests.TestClip testMethod=test_clip_init_default>

    def test_clip_init_default(self):
        clipmixin = self.create_clipmixin()
    
        # UserWarning because we have a narrow clip
>       with pytest.warns(UserWarning):
E       Failed: DID NOT WARN. No warnings of type (<class 'UserWarning'>,) were emitted. The list of emitted warnings is: [].

tests/mixin_tests.py:593: Failed
=============================== warnings summary ===============================

Comment 1 Elliott Sales de Andrade 2022-11-26 22:11:36 UTC
Reported upstream.

Comment 2 Ben Cotton 2023-02-07 14:59:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 4 Fedora Update System 2023-02-20 03:37:12 UTC
FEDORA-2023-aa0e1d74f3 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-aa0e1d74f3

Comment 5 Fedora Update System 2023-02-20 03:40:04 UTC
FEDORA-2023-aa0e1d74f3 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2023-02-20 03:43:26 UTC
FEDORA-2023-8bd991ddca has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-8bd991ddca

Comment 7 Fedora Update System 2023-02-20 03:46:04 UTC
FEDORA-2023-8bd991ddca has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.