Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2148781 - osinfo-db-tools x86_64 contains mingw localization
Summary: osinfo-db-tools x86_64 contains mingw localization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: osinfo-db-tools
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2151985
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-27 22:21 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2023-02-28 03:03 UTC (History)
4 users (show)

Fixed In Version: osinfo-db-tools-1.10.0-6.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-28 03:03:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2022-11-27 22:21:27 UTC
Description of problem:
x86_64 build of osinfo-db-tools includes MinGW localizations.

Version-Release number of selected component (if applicable):
osinfo-db-tools-1.10.0-4.fc37.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql osinfo-db-tools|grep -E 'mingw32.*mo'|wc -l

Actual results:
32

Expected results:
0

Comment 1 Daniel Berrangé 2022-12-08 19:15:11 UTC
The problem is that %mingw_find_lang clobbers the %find_lang content. I filed bug 2151985, as I think its better to fix it at source. If that can be fixed quickly enough, its not worth adding a short term workaround in osinfo-db-tools

Comment 2 Dominik 'Rathann' Mierzejewski 2023-01-12 10:39:31 UTC
Bug 2151985 has been fixed. Please rebuild with the latest mingw-filesystem package (mingw-filesystem-143-1.fc37).

Comment 3 Fedora Update System 2023-02-22 13:07:08 UTC
FEDORA-2023-bd951ae64b has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-bd951ae64b

Comment 4 Fedora Update System 2023-02-23 03:02:28 UTC
FEDORA-2023-bd951ae64b has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-bd951ae64b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-bd951ae64b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2023-02-28 03:03:36 UTC
FEDORA-2023-bd951ae64b has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.