Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2148957 - F38FailsToInstall: yubikey-manager-qt
Summary: F38FailsToInstall: yubikey-manager-qt
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yubikey-manager-qt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-11-28 12:11 UTC by Miro Hrončok
Modified: 2023-02-07 10:52 UTC (History)
2 users (show)

Fixed In Version: yubikey-manager-qt-1.2.5-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-07 10:52:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 2166928 0 unspecified CLOSED yubikey-manager-qt 1.2.5 is available 2023-02-07 10:38:46 UTC

Description Miro Hrončok 2022-11-28 12:11:51 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (yubikey-manager-qt) Fails To Install in Fedora 38:

can't install yubikey-manager-qt:
  - nothing provides python3-yubikey-manager < 5 needed by yubikey-manager-qt-1.2.4-6.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install yubikey-manager-qt


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-12-05 17:34:38 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Jakub Jelen 2022-12-06 16:22:09 UTC
This is related to the bug #2143324 which was broken by non-backward compatible update of yubikey-manager. Adding Gerald for reference.

Comment 3 Gerald Cox 2022-12-07 13:42:24 UTC
Correct.  Both yubioath-desktop and yubikey-manager-qt rely on yubikey-manager (ykman) to provide basic functionality. 
Upstream expects yubikey-manager-qt will be functional with the current ykman 1st qtr 2023, but no guarantees. 
The new version of yubioath-desktop is a flutter implementation which is currently not supported in Fedora, and
even if it was, it appears that the way the dependencies are bundled would preclude inclusion in the Fedora 
repositories. I've created a script ykocli which frontends ykman to mimic yubioath-desktop functionality.  People
can also of course either enter the ykman commands manually or just download the flutter binary directly from the yubico
website: https://www.yubico.com/products/yubico-authenticator/

Comment 4 Gerald Cox 2023-01-21 14:42:31 UTC
I've added an item here which explains the situation and provides mitigation:
https://discussion.fedoraproject.org/t/f38-yubioath-desktop-yubikey-manager-qt-will-no-longer-be-available-in-fedora-repository/45921

It appears that upstream will provide an update for yubikey-manager-qt to resolve this issue in time
for F38.  That information is also in the above link.

LMK if you need more information/clarification.  

Thanks!

Comment 5 Gerald Cox 2023-02-03 14:23:28 UTC
yubikey-manager-qt 1.2.5 which resolves the issue is now available
https://bugzilla.redhat.com/show_bug.cgi?id=2166928

Comment 6 Jakub Jelen 2023-02-07 10:52:31 UTC
Built in rawhide so this should be resolved.

https://bodhi.fedoraproject.org/updates/FEDORA-2023-9dbdc53b10


Note You need to log in before you can comment on or make changes to this bug.