Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2152665 - sword-1.9.0-16.fc39 FTBFS with Python 3.12: ModuleNotFoundError: No module named 'distutils'
Summary: sword-1.9.0-16.fc39 FTBFS with Python 3.12: ModuleNotFoundError: No module na...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: sword
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 2226477 (view as bug list)
Depends On:
Blocks: F39FTBFS F40FTBFS PYTHON3.12 2220606
TreeView+ depends on / blocked
 
Reported: 2022-12-12 16:11 UTC by Tomáš Hrnčiar
Modified: 2023-09-26 10:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-26 10:06:02 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2022-12-12 16:11:43 UTC
sword fails to build with Python 3.12.0a3.

Traceback (most recent call last):
  File "/builddir/build/BUILD/sword-1.9.0/redhat-linux-build/bindings/swig/python3/setup.py", line 3, in <module>
    from distutils.core import setup, Extension
ModuleNotFoundError: No module named 'distutils'

Remove the distutils package. It was deprecated in Python 3.10 by PEP 632 “Deprecate distutils module”. For projects still using distutils and cannot be updated to something else, the setuptools project can be installed: it still provides distutils. (Contributed by Victor Stinner in gh-92584.)

https://docs.python.org/3.12/whatsnew/3.12.html

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.12/fedora-rawhide-x86_64/05127762-sword/

For all our attempts to build sword with Python 3.12, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.12/package/sword/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.12:
https://copr.fedorainfracloud.org/coprs/g/python/python3.12/

Let us know here if you have any questions.

Python 3.12 is planned to be included in Fedora 39. To make that update smoother, we're building Fedora packages with all pre-releases of Python 3.12.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 greg.hellings 2022-12-12 16:32:30 UTC
Is it appropriate for me to add a dependency on python3-setuptools or similar in the BR for the spec?

Comment 2 Ben Cotton 2023-02-07 15:00:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 3 Petr Pisar 2023-07-27 06:41:43 UTC
*** Bug 2226477 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Release Engineering 2023-08-16 07:06:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 5 Fedora Admin user for bugzilla script actions 2023-09-05 00:53:55 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 6 Miro Hrončok 2023-09-26 10:06:02 UTC
Automation has figured out the package is retired in Fedora 39.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.