Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2156350 - F38FailsToInstall: ghc-hadolint, ghc-hadolint-devel, ghc-hadolint-prof
Summary: F38FailsToInstall: ghc-hadolint, ghc-hadolint-devel, ghc-hadolint-prof
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: hadolint
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-12-26 15:57 UTC by Fedora Fails To Install
Modified: 2022-12-29 17:45 UTC (History)
3 users (show)

Fixed In Version: hadolint-2.8.0-9.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-12-29 17:45:40 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2022-12-26 15:57:11 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (hadolint) Fails To Install in Fedora 38:

can't install ghc-hadolint:
  - nothing provides libHSShellCheck-0.8.0-C540WicoAlF4cy61feCQNQ-ghc8.10.7.so()(64bit) needed by ghc-hadolint-2.8.0-8.fc38.x86_64
  
can't install ghc-hadolint-devel:
  - nothing provides ghc-devel(ShellCheck-0.8.0-C540WicoAlF4cy61feCQNQ) needed by ghc-hadolint-devel-2.8.0-8.fc38.x86_64
  
can't install ghc-hadolint-prof:
  - nothing provides ghc-prof(ShellCheck-0.8.0-C540WicoAlF4cy61feCQNQ) needed by ghc-hadolint-prof-2.8.0-8.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install ghc-hadolint ghc-hadolint-devel ghc-hadolint-prof


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Jens Petersen 2022-12-29 05:45:43 UTC
Sorry this is my bad - well ShellCheck was bumped to 0.9.0 in Rawhide
and forgot to think about this dependent package.

Comment 2 Dridi Boukelmoune 2022-12-29 07:45:02 UTC
I would have built it for rawhide myself if I got a chance after bug 2155800 was solved, the only difference being that I wasn't aware of hadolint until now and can't rebuild it myself.

In theory a rebuild should be enough, it depends on ShellCheck >=0.8.0, or did such an attempt fail?

Comment 3 Jens Petersen 2022-12-29 09:11:38 UTC
(In reply to Dridi Boukelmoune from comment #2)
> I would have built it for rawhide myself if I got a chance after bug 2155800
> was solved, the only difference being that I wasn't aware of hadolint until
> now and can't rebuild it myself.

No worries

> In theory a rebuild should be enough, it depends on ShellCheck >=0.8.0, or
> did such an attempt fail?

No it didn't fail :)
I just added you for awareness, thank you

Probably best to try to coordinate updates in future, or maybe you can also request access to ShellCheck for this.
I am also quite happy to help out since I am a ProvenPackager and looking over our Haskell packages in general. :-)

Comment 4 Dridi Boukelmoune 2022-12-29 09:15:13 UTC
> or maybe you can also request access to ShellCheck for this.

You probably meant access to hadolint, will do.

Comment 5 Fedora Fails To Install 2022-12-29 17:45:40 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 38.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.