Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2162433 - Upgraded python-packaging breaks cekit
Summary: Upgraded python-packaging breaks cekit
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cekit
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Goldmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2168136 (view as bug list)
Depends On:
Blocks: F38FailsToInstall 2166942
TreeView+ depends on / blocked
 
Reported: 2023-01-19 14:52 UTC by Tomáš Hrnčiar
Modified: 2023-03-26 13:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-26 13:12:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2023-01-19 14:52:15 UTC
Hello,

I am working on upgrading python-packaging to version 23.0 and it might break cekit on runtime since rpm shows version constraint. Could you please check if your package works with packaging 23.0 (you can use this COPR https://copr.fedorainfracloud.org/coprs/thrnciar/python-packaging/builds/)? I plan to ship the update next week on Thursday 26.1.2023.

Thank you. 

cekit-0:4.5.0-1.fc38.noarch
(python3.11dist(packaging) < 22~~ with python3.11dist(packaging) >= 19)

Comment 1 Nick Cross 2023-01-19 15:52:31 UTC
It is likely it will fail - see https://github.com/cekit/cekit/issues/830 We will have to explicitly code the update to the latest packaging.

Comment 2 Miro Hrončok 2023-01-20 11:24:59 UTC
> We will have to explicitly code the update to the latest packaging.

Do we need to wait with the update? (We'd rather not.) Or do you need a python-packaging-21 compact package?

Comment 3 Nick Cross 2023-01-20 12:23:11 UTC
There is no need to wait. I have entered https://github.com/cekit/cekit/issues/837 and will look at this for the next version of CEKit.

Comment 4 Ben Cotton 2023-02-07 15:06:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 5 Miro Hrončok 2023-02-08 09:43:17 UTC
*** Bug 2168136 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Fails To Install 2023-02-15 12:25:15 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 7 Fedora Fails To Install 2023-03-09 20:56:39 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 4+ weeks.
This is the second reminder (step 4) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 8 Fedora Fails To Install 2023-03-18 07:43:20 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 39.

Thanks for taking care of it!

Comment 9 Fedora Fails To Install 2023-03-26 13:12:30 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 38.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.