Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2163827 - F38FailsToInstall: davix-tests
Summary: F38FailsToInstall: davix-tests
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: davix
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mihai Patrascoiu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2023-01-24 14:01 UTC by Fedora Fails To Install
Modified: 2023-01-24 17:55 UTC (History)
5 users (show)

Fixed In Version: davix-0.8.3-4.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-01-24 17:55:25 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-01-24 14:01:10 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (davix) Fails To Install in Fedora 38:

can't install davix-tests:
  - nothing provides libgtest.so.1.12.1()(64bit) needed by davix-tests-0.8.3-3.fc38.x86_64
  - nothing provides libgtest_main.so.1.12.1()(64bit) needed by davix-tests-0.8.3-3.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install davix-tests


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-01-24 14:52:05 UTC
This is due to an unannounced .so version bump in gtest.

https://bugzilla.redhat.com/show_bug.cgi?id=2161870#c3

Comment 2 Ben Beasley 2023-01-24 16:08:33 UTC
A simple rebuild won’t suffice, since gtest 1.13.0 dropped support for C++ standards older than C++14. See https://src.fedoraproject.org/rpms/davix/pull-request/3 for a suggestion and some comments.


Note You need to log in before you can comment on or make changes to this bug.