Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2163832 - F38FailsToInstall: gfal2-tests
Summary: F38FailsToInstall: gfal2-tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gfal2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Wright
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2023-01-24 14:01 UTC by Fedora Fails To Install
Modified: 2023-01-28 18:16 UTC (History)
6 users (show)

Fixed In Version: gfal2-2.21.2-3.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-01-28 18:16:45 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-01-24 14:01:21 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (gfal2) Fails To Install in Fedora 38:

can't install gfal2-tests:
  - nothing provides libgtest.so.1.12.1()(64bit) needed by gfal2-tests-2.21.2-2.fc38.x86_64
  - nothing provides libgtest_main.so.1.12.1()(64bit) needed by gfal2-tests-2.21.2-2.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install gfal2-tests


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-01-24 14:52:29 UTC
This is due to an unannounced .so version bump in gtest.

https://bugzilla.redhat.com/show_bug.cgi?id=2161870#c3

Comment 2 Fedora Update System 2023-01-28 18:13:09 UTC
FEDORA-2023-3b5014a630 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-3b5014a630

Comment 3 Fedora Update System 2023-01-28 18:16:45 UTC
FEDORA-2023-3b5014a630 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.