Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2164641 - binaryen: FTBFS in Fedora Rawhide with GCC13
Summary: binaryen: FTBFS in Fedora Rawhide with GCC13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: binaryen
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 2171448 2225722 (view as bug list)
Depends On:
Blocks: F38FTBFS F39FTBFS F40FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-01-25 21:20 UTC by Ben Beasley
Modified: 2023-09-28 01:35 UTC (History)
2 users (show)

Fixed In Version: binaryen-116-1.fc39 binaryen-116-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-28 00:20:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github WebAssembly binaryen issues 5456 0 None open spec/f32.wast test 1603 fails with GCC 13 2023-01-30 13:51:15 UTC

Description Ben Beasley 2023-01-25 21:20:49 UTC
Description of problem:
Package binaryen fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
111-1.fc38

Steps to Reproduce:
koji build --scratch f38 binaryen-111-1.fc38.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/binaryen

In file included from /builddir/build/BUILD/binaryen-version_111/src/wasm/wat-lexer.cpp:25:
/builddir/build/BUILD/binaryen-version_111/src/wat-lexer.h:62:3: error: 'uint64_t' does not name a type
   62 |   uint64_t n;
      |   ^~~~~~~~
/builddir/build/BUILD/binaryen-version_111/src/wat-lexer.h:20:1: note: 'uint64_t' is defined in header '<cstdint>'; did you forget to '#include <cstdint>'?
   19 | #include <iterator>
  +++ |+#include <cstdint>
   20 | #include <optional>

https://www.gnu.org/software/gcc/gcc-13/porting_to.html

Comment 2 Dominik 'Rathann' Mierzejewski 2023-01-30 13:51:15 UTC
With missing header includes fixed, there's one new test failure now.

Comment 3 Ben Cotton 2023-02-07 15:12:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 4 Dominik 'Rathann' Mierzejewski 2023-02-22 13:47:43 UTC
*** Bug 2171448 has been marked as a duplicate of this bug. ***

Comment 5 Dominik 'Rathann' Mierzejewski 2023-09-01 07:10:00 UTC
*** Bug 2225722 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2023-09-19 20:58:14 UTC
FEDORA-2023-b0d4d11973 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b0d4d11973

Comment 7 Fedora Update System 2023-09-19 20:58:14 UTC
FEDORA-2023-6154f6f0b0 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-6154f6f0b0

Comment 8 Fedora Update System 2023-09-20 01:16:01 UTC
FEDORA-2023-b0d4d11973 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-b0d4d11973`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-b0d4d11973

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2023-09-20 02:08:22 UTC
FEDORA-2023-6154f6f0b0 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-6154f6f0b0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-6154f6f0b0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-09-28 00:20:27 UTC
FEDORA-2023-6154f6f0b0 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2023-09-28 01:35:45 UTC
FEDORA-2023-b0d4d11973 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.