Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2166607 - python-ansible-pygments FTBFS with Pygments 2.14
Summary: python-ansible-pygments FTBFS with Pygments 2.14
Keywords:
Status: CLOSED DUPLICATE of bug 2220111
Alias: None
Product: Fedora
Classification: Fedora
Component: python-ansible-pygments
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS PYTHON3.12 2157264
TreeView+ depends on / blocked
 
Reported: 2023-02-02 10:15 UTC by Karolina Surma
Modified: 2023-09-26 09:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-26 09:54:11 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Karolina Surma 2023-02-02 10:15:54 UTC
Description of problem:
python-ansible-pygments will stop building with Pygments 2.14 in Fedora Rawhide.

Version-Release number of selected component (if applicable):
0.1.1-4

How reproducible:
Always

Steps to Reproduce:
$ mock -r fedora-rawhide-x86_64 --addrepo=https://download.copr.fedorainfracloud.org/results/ksurma/pygments-2.140/fedora-rawhide-x86_64/ --no-clean your.src.rpm

$ mock -r fedora-rawhide-x86_64 --addrepo=https://download.copr.fedorainfracloud.org/results/ksurma/pygments-2.9.0/fedora-rawhide-x86_64/  shell

Actual results:
https://download.copr.fedorainfracloud.org/results/ksurma/pygments-2.14/fedora-rawhide-x86_64/05362822-python-ansible-pygments/builder-live.log.gz

Expected results:
Build succeeds

Additional info:
It looks like it has been fixed upstream: https://github.com/ansible-community/ansible-pygments/commits/main

Comment 1 Ben Cotton 2023-02-07 15:07:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 38 development cycle.
Changing version to 38.

Comment 2 Fedora Admin user for bugzilla script actions 2023-09-23 00:46:25 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Miro Hrončok 2023-09-26 09:54:11 UTC

*** This bug has been marked as a duplicate of bug 2220111 ***


Note You need to log in before you can comment on or make changes to this bug.