Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2167121 - dnsmasq-2.89 is available
Summary: dnsmasq-2.89 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL: https://lists.thekelleys.org.uk/piper...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-02-04 23:44 UTC by Upstream Release Monitoring
Modified: 2023-02-17 18:16 UTC (History)
4 users (show)

Fixed In Version: dnsmasq-2.89-1.fc39 dnsmasq-2.89-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-17 18:16:29 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Upstream Release Monitoring 2023-02-04 23:44:14 UTC
Releases retrieved: 2.89
Upstream release that is considered latest: 2.89
Current version/release in rawhide: 2.88-3.fc38
URL: http://www.thekelleys.org.uk/dnsmasq/doc.html

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/444/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dnsmasq

Comment 1 Upstream Release Monitoring 2023-02-04 23:44:20 UTC
Scratch build failed. Details below:

GenericError: Invalid method: krb_login
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 195, in build
    session = self._session_maker()
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 422, in _session_maker
    result = koji_session.krb_login(
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 2362, in __call__
    return self.__func(self.__name, args, opts)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 2874, in _callMethod
    raise err

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Petr Menšík 2023-02-13 19:51:59 UTC
From upstream changelog:
Fix bug introduced in 2.88 (commit fe91134b) which can result
in corruption of the DNS cache internal data structures and
logging of "cache internal error". This has only been seen
in one place in the wild, and it took considerable effort
to even generate a test case to reproduce it, but there's
no way to be sure it won't strike, and the effect is to break
the cache badly. Installations with DNSSEC enabled are more
likely to see the problem, but not running DNSSEC does not
guarantee that it won't happen. Thanks to Timo van Roermund
for reporting the bug and for his great efforts in chasing
it down.
    
Also --no-ident option to disable CHAOS entries.

Building already rawhide update.

Comment 3 Fedora Update System 2023-02-13 21:56:22 UTC
FEDORA-2023-40edff3a21 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-40edff3a21

Comment 4 Fedora Update System 2023-02-14 01:58:36 UTC
FEDORA-2023-40edff3a21 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-40edff3a21`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-40edff3a21

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2023-02-17 18:16:29 UTC
FEDORA-2023-40edff3a21 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.